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Author’s Note

Writing this manual has provided me with a valuable opportunity to study ASIC design,
which bears significant difference from the analog design that | was accustomed to doing. During
this enriching process, | gained understanding of ASIC design and learn all the EDA tools
required for it. All of this commenced with a search for books on ASIC design to mastering EDA
tools and finally finishing the manual after a year’s effort. | strived to make the contents, to the
largest extent possible, parallel to practical work. May this manual become the handy guide for
our students and staff who will be doing ASIC design. | hope that you may kindly provide me

with useful feedback. Please email me at elezhg@nus.edu.sg.

Zheng Huan Qun
16 March 2006



This manual describes the method of ASIC design from front-end to back-end using cadence

ASIC Design Manual

1. Introduction

NCLaunch, cadence silicon ensemble, synopsys chip synthesis and primetime.

The manual is meant for the beginners of ASIC design. The usages of the cadence and
synopsys tools are demonstrated with graphic user interface (GUI), for users understand easily

and apply conveniently.

1.1 Prerequisite

Users need to know Hardware Description Language (HDL), either VHDL or Verilog, and

are able to write RTL code with HDL. Users must have the knowledge of digital circuits.

1.2 Overview of ASIC Design

ASIC design flow is shown in figure 1-1. As it shows, the front-end design includes RTL
coding, RTL functionality verification, synthesis, pre-layout verification and pre-layout static
time analysis (STA), and the back-end design includes place and route, post-layout verification

and post-layout STA.

Bl

RTL Coding

r

RTL Simulation & Verification
with Cadence NCLaunch

k.

r

Logic Synthesis

& Optimization

with Synopsys Chip Synthesis

r

Pre-layout Verification
with Cadence NCLaunch

r

Pre-layout STA

with Synopsys PrimeTime

Front End Design

F Y

o

Place & Route
with Cadence Silicon Ensemble

Post-layout
with Cadenc

Verification
¢ NCLaunch

Post-layout STA
with Synopsys PrimeTime

Back En

c

Tape out

Figure 1-1 ASIC design flow.

_________ —

d Design
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The explanation of the flow is as follows.

= RTL coding — to code design with HDL.

= RTL Simulation & Verification — to simulate the RTL code and verify that the code
is logically and functionally right.

= Logic Synthesis & Optimization — to synthesis and optimize the code and get the gate
level netlist of the design.

= Pre-layout Verification — to verify that the gate level netlist satisfies the
specifications of the design.

= Pre-layout STA - to do static timing analysis with standard cell delays and wire load
models.

» Place & Route - to get the layout of the design.

= Post-layout Verification — to verify the layout level netlist satisfies the specifications
of the design.

= Post-layout STA — to do static timing analysis with standard cell delays, net delays
and parasitics.

The design can be taped out if the design satisfies its specifications after post-layout STA. If
not, it has to be brought back to synthesize and optimize again. If no matter how hard the
synthesis level it takes and the design still cannot meet the specifications, modifying the source
(RTL) code has to be considered.

1.3 Arrangement of the Manual

RTL coding style affects the final chip synthesis results directly, so understanding the
hardware implications for coding constructs is important. The hardware implications for code - if-
else, case and for loop are described briefly in chapter 2. Advanced users may refer to synopsys
documents or HDL books for more information.

In chapter 3, the usage of cadence NCLaunch is described and demonstrated. The steps to
compile, elaborate and simulate a Verilog (or VHDL) design are listed in details, and the steps to
save & view output data are listed in details too. The verification of RTL code using NCLaunch is
demonstrated with a 32 bit adder. The method described in this chapter will be used during pre-
layout and post-layout verification.

Once it is verified that the RTL code is logically and functionally right. The code is brought
to synopsys chip synthesis for synthesizing and optimizing to get a gate level netlist. The method
of synthesis and optimization is described, and the normal steps of running chip synthesis are
listed in chapter 4. The whole flow is demonstrated with the 32 bit adder RTL code which has
passed the verification in chapter 3.

Does the gate level netlist meet the specifications of the design? A pre-layout verification
needs to be done using NCLaunch. The difference between pre-layout and RTL code verification
is that the standard cell delays are considered while simulating the pre-layout netlist (the gate
level netlist). The delay information is saved in a standard delay format (SDF) file which is got
from chip synthesis. Chapter 5 focuses on SDF back annotation system task. The demonstration
is done with the 32 bit gate level netlist which is the output of chapter 4.

In chapter 6, the pre-layout STA using primetime is described. Pre-layout STA is to check
the timing of the design. The method of doing STA using primetime is demonstrated with the 32
bit adder gate level netlist in this chapter.



After the design is verified, its gate level netlist can be brought to cadence silicon ensemble
for place and route to get its layout. The full steps from setting up library, floor planning, cell
placement, power ring creation and clock generation to route are demonstrated with the design

ASIC Design Manual

example — 32 bit adder in chapter 7.

Post-layout verification is presented and demonstrated in chapter 8. Like pre-layout
verification, SDF back annotation is used to annotate the design. The difference between post-
layout and pre-layout verification is that the post-layout SDF file includes both delays of standard
cells and nets while pre-layout SDF file has the standard cell delays only.

Post-layout STA using primetime is described in chapter 9. A SDF file including delay
information of the design and a reduced standard parasitic format (RSPF) file including the
parasitics are used to back annotate the design during STA. The method to back annotate the

design is demonstrated with the 32 bit adder in this chapter.

1.4 Environment setup

To use the ASIC design manual, the following tools are needed,

The environment setup for using the above tools has to be done. Ask your system

Cadence NCLaunch,
Cadence Silicon Ensemble,
Synopsis Chip Synthesis, and
Synopsys PrimeTime.

administrator for help.
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2. Coding for Synthesis

Code that is functionally equivalent, but coded differently, will give different synthesis
results. User cannot rely solely on Design Complier (DC) to fix a poorly coded design. Try to
understand the “hardware” coded, to give DC the best possible starting point. The three big
guidelines to write RTL code are as follows.

=  Write HDL hardware descriptions and think of the topology implied by the code.

= Do not write HDL simulation models without explicit delays and file 1/0.

= |solate asynchronous logic from synchronous logic as synchronous designs run
smoothly through synthesis test, simulation, and layout.

Keep in mind that writing in an RTL coding style means describing the register architecture,
circuit topology and functionality between registers, and that DC optimizes logic between
registers only not the register placement.

This chapter describes briefly hardware implication for some statements: if, case and loop.
Partitioning a design is presented in this chapter, too.

2.1 if statements

> if-else statements

Code 1: Code 2:
if (SEL="1") then if (SEL==1"b1)
SUM<=A+B; begin
else OP1=A;
SUN<=C+D; OP2=B;
End if; end
else
begin
Opl=C;
Op2=D:
end
SUM=0p1+0p2;

Code 1 construct implies multiplexing hardware figure 2-1 (a) or figure 2-1 (b). Code 2 implies
figure 2-1 (b) only. Both codes are functionally same.

A
B
A
SUM o
c SEL SUM
b B
SEL D

@) (b)

Figure 2-1 Implication of if-else.
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> if statements and Latches

Any signal that is not fully specified for all conditions infers a latch. Below is the code
example of VHDL/Verilog.

VHDL code 1: Verilog code 2:
LS373: process (ALE, ADBUS) | Always @ (ALE or ADBUS)
begin begin
If (ALE="1") then If (ALE)
ABUS<=ADBUS; ABUS=ADBUS;
end if; end
end process LS373

> if-then-elseif statements

VHDL and Verilog if-elseif statements imply priority, use only if priority checking is a circuit
requirement. Priority control logic will be synthesized, resulting in a larger and possibly slower
logic, if it is used. An example is shown below, and its implication is shown in figure 2-2.

module IPC(active[3:0], int0, intl, int2, int3)
input int0, intl, int2, int3;

output [3:0] active;

reg int0, intl, int2. int3;

reg[3:0] active;

always@(int0 or intl or int2 or int3) begin
active[3:0] = 4°b0000;
if (int0) active[0]=1"b1;
else if (intl) active[1]=1"b1;
else if (int2) active[1]=1"b1;
else if (int3) active[1]=1"b1;
end; endmodule

int0 —> I > active[0]

it '_CD_D active[1]
, VD—D active[2]
int2 —>

D_FD_D active[3]

Figure 2-2 Implication of if-then-elseif.

!

L

int3 —

There are cases where there is no need to use if-then-elseif, and they are
= when input signals have equal priority (no priority over each other), and
= when signals are mutually exclusive.
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2.2 Case Statements

Case statements imply parallel MUX function, as shown in figure 2-3. The actual gates
synthesized might not be a 4:1 MUX, and they depend on the target library used.

VHDL code: Verilog code:
process (SEL, A, B, C, D) begin always@(SEL or A or Bor C or D)
case SEL is begin
when “00”"=>0UTC <= A; case (SEL)
when “01”"=>0UTC <= B; 2°b00: OUTC = A;
when “10”=>0UTC <= C; 2'b01: OUTC =B;
when others=> QUTC <= D; 2'b10: OUTC =C;
end case; default : OUTC =D;
end process; endcase
end

Figure 2-3 Implication of case statements.

2.3 Loop statements
» Unrolling loops

In synthesis, for loops are “unrolled” during translation, and then synthesized. For the code
below, its hardware is shown in figure 2-4.

VHDL code: Verilog code:
Process(a, b) integer i;
begin
for i ir_1 0to3 _Ioop _ always@(a or b) begin_
out(i) <= a(i) and b(3-i); for (i=0;i<=3;i=i+l)
end loop; Out[i] = a[i] & b[3-i];
end process; end
a(0) .—— .
bES) ;_} ~ out(0)
a(1)— —
b(2) .:;:D——-' out(1)
a(2) — I
a(3) ——| _—
BO) l__D— > out(3)

Figure 2-4 Implication of unrolled loop.
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» Tradeoffs with loops

VHDL code: Verilog code:
process (data) always@ (data)
variable sum; integer; begin
begain sum = 0;
sum: =0; /*count the numer of “1’s*/
-- count the 1’s for(i=0;i<8;i=i+l)
foriin0to 7 loop sum = sum + data[i];
sum := data(i) + sum;
end loop I* check if even or odd number */
odd_parity = sum[0]
-- check parity
odd_parity <= sum mod 2; end
end process

The hardware for the above code is shown in figure 2-5.

data(3) data(6)
data(0) o
data(1) data(7) o

Figure 2-5 Implication of tradeoffs with loop.

» Recoded loop

VHDL code: Verilog code:

process (data) always@ (data)

variable odd-parity : bit; begin

begin for (i=0;i <=8; i=i+l)
odd_parity <= “0’; odd_parituy = "data[i];
foriin0to 7 loop end

odd_parity <= data(i) xor odd_parity;

end loop;

end process

The hardware implication of the above code is shown in figure 2-6.

R e
— ) - O A0
.-jj:_-)’ unrolled :;LI___\)
o= >
F>— 5

optimized design

Figure 2-6 Implication of recoded loop
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2.4 Partitioning a Design

Partitioning is the process of dividing complex design into smaller parts. Ideally, all partitions
would be planned prior to writing any RTL. Initial partitions of a design are defined by RTL, but
it can be modified using DC by the commands: group and ungroup®. The followings determine
the partitions within the RTL description.

= Entity and module statements define hierarchical blocks,
= Inference of arithmetic circuits (+, -, *, ..) can create a new level of hierarchy, and
Process and Always statements do not create hierarchy.

The partitioning strategies for synthesis are shown below.
= Don’t separate combinational logic across hierarchical boundaries.
= Place hierarchy boundaries at register outputs.
= Size blocks for reasonable runtimes.
= Separate core logic, pads, clocks, asynchronous logic and JTAG.

A design with better partitioning brings
= Detter results: smaller and faster design,
= easier synthesis process: simplified constraints and scripts, and
= faster compiles: quicker turnaround.
Remember: always plan the partitioning of design prior to start writing RTL code.

2.5 Conclusion
This chapter lists the hardware implications for some statements, and highlights the

importance of partitioning a design. Reader should keep these in mind and remember that DC
optimizes logic between registers only not the register placement.

! Refer to Synopsys Design Compiler document for details.
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3. RTL Simulation and Verification with Cadence NCLaunch

Once coded, simulation and verification should be done to verify the code and its
functionality. This can be achieved with either cadence tool (NCLaunch) or synopsys tool (VCS).
In this manual, NCLaunch is introduced and used.

The arrangement is as follows. In section 3.1, an introduction to NCLaunch software is
presented. In section 3.2, a tutorial of using NCLaunch is preformed. The method of debugging a
design is given in section 3.3. The conclusion is given in section 3.4. The whole process is
demonstrated with a 32 bit adder which is coded with Verilog.

3.1 Introduction to NCLaunch

NCLaunch provides user with a graphical user interface to configure and launch cadence
simulation tools: compiler, elaborator and simulator. The following concepts are described in this
section, which user should be familiar before running NCLaunch.

e Invoking NCLaunch
Single-Step and Multi-Step Modes
Components of NCLaunch
Exiting NCLaunch
The NCLaunch Help Menu

3.1.1 Invoking NCLaunch

On UNIX system, invoke NCLaunch with the following commands.
% nclaunch —new? (first time)
% nclaunch (afterwards)
When NCLaunch starts for the first time, it prompts user to select a running mode, single-step and
multi-step, as shown in figure 3-1.

gi NCLaunch I iJ

NCLaunch 05.10-p004

Flease Zelect Run hode:

Multiple Step
Single Step (NCVerilog Only)
Help

Exit

Figure 3-1 Select running mode.

% There are more options. Please refer to NCLunch User Guide for details
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3.1.2 Single-Step and Multi-Step Modes

NCLaunch allows user to invoke the simulator in one of the following two modes:

In multi-step mode®, user performs separate steps to compile source files, elaborate
design units, and simulate snapshots for Verilog, VHDL, and mixed-language designs.
This gives user greatest control and flexibility to specify simulation options and features.

Multiple step mode uses the ncvlog and ncelab commands to compile and elaborate
design.

In single-step mode*, user compiles, elaborates, and simulates a design in one step. For
designs entirely written in Verilog, this provides an easy way to select NC-Verilog
options and run the simulation. Single-step mode creates everything needed to run the
NC-Verilog simulator, including all directories, a cds.lib file, and an hdl.var file.

Single step mode uses the ncverilog command to compile and elaborate design.

User can switch mode at any time by selecting File>Switch to Multiple Step or
File->Switch to Single Step.

3.1.3 Components of NCLaunch

The NCLaunch main window contains a menu bar, toolbar, file browser or design area, and
an /O region. Figures 3-2 and 3-3 show the main window in multi-step mode and single-step
mode respectively.

Menu Bar contains the File, Edit, Tools, Utilities, Plug-ins, and Help menu choices.
ToolBar consists of icons that invoke cadence NC simulation tools and utilities. The tool
icons give user a shortcut to the tools, as shown in Table 3-1.

I/0 Region and Status Bar let user submit batch commands to simulation tools and
utilities and view the output of running process. Standard output messages from running
processes are displayed in blue and error messages are displayed in red.

—| NClLaunch : /home/staff/elezhq/ASIC/ASIC_data/sim| - | |
Eile Edit Tools Utilities  Blug=Ins Help

Browsers: ";,*? Tools: 7 \{«I ﬁi.éj

Directary:jome/stafifelezhafASIC/ASIC_t ] ([ oy amesstaelezharaSIC/ASIC_datarsin
] S || By worklib

®0 INCA_libs #-1 Snapshots

E-1 il_verilog

B0 waves.shm

adderdz.v

L topy -
Filters:|* v *.vhd whl ~ |5 - ~
nclaunch=

| 0 items selected |

Figure 3-2 NCLaunch main window, multi-step mode.

%4 For more information, refer to the NC-Verilog Simulator Help.
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—|NCLaunch : /home/staff/elezhq/ASIC/ASIC_data/sim| - | _||
Eile Edit Tools Utilities Plug-Ins  Buttons Help
Browsers: ";,ﬁ Tools: gj
Directury:;1Dmea’staﬁfelethf.’-‘-.SICa’f-‘-.SIC_ j Design |
L - s
# 1 INCA_libs —|
B0 il_verilog _’J ﬁ]
'I__'I waves.shm 4 L
adder3z.y _l j
B topy ¥ i
Filters:i".v j‘
nclaunchz=
|U_items selected ||
Figure 3-3 NCLaunch main window, single-step mode.
Table 3-1 Icons of the toolbar.
Icons Function
-4 | Edit File — by selecting a file and clicking on this icon, a text editor appears with the

file’s contents for review or modification.

Refresh — Updates user’s browser window.

Compile VHDL Files (multi-step only) — compiles selected VHDL files that appear as
design units under user’s work library in the Library Browser.

Compile Verilog Files (multi-step only) — compiles selected Verilog files that appear as
design units under user’s work library in the Library Browser.

Elaborate Files (multi-step only) — by selecting the top level design unit and clicking on
this icon, user’s design is elaborated.

Run Simulation — starts a simulation of selected design.

Launch analysis & lint with current selection

Browser Logfiles — launches the NCBrowse message browser to analyze selected log
files.

Waveform Viewer — starts the SimVision analysis environment with selected database
files.

nclaunchs

Figure 3-4 1/O region.
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3.1.4 Exiting NCLaunch
To exit NCLaunch, select File=>Exit.
Exiting the application does not terminate any batch jobs that user has already launched. On

exit, NCLaunch saves general default settings to user’s home directory, and saves design default
setting to user’s current working directory.

3.1.5 Environment Setup
User can run NCLaunch in one of the two modes, single step or multiple step. As mentioned
in section 3.1.2, single step mode provides all the necessary setup files (cds.lib and hdl.var), while

multiple step mode creates those setup files through a few steps of setting. A sample of setting
environment is shown in section 3.2.1.

3.2 Tutorial of Using NCLaunch

The sample used here is a 32 bit adder, and its source code adder32.v and test_adder.v are
listed in tables 3-2 and 3-3 respectively. The file test_adder.v which tests the function of the
adder32.v is the top design.

Table 3-2 Source code of 32 bit adder.

[[file: ~/project/rtl_verilog/adder32.v
module adder32 (a, b, cin, CLOCK, sum, cout);
input [31:0] a, b;

input cin, CLOCK;

output [31:0] sum;

output cout;

reg [31:0] sum;

reg cout;

reg [32:0] temp;

always @(a or b or cin)

begin

temp=a+b+cin;

end

always @(posedge CLOCK)
begin

{cout, sum}<=temp[32:0];
end

endmodule
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Table 3-3 Test bench of the 32 bit adder.

[[file: ~/project/rtl_verilog/test_adder.v
module test_adder;

reg [31:0] a, b;

reg cin, CLOCK;

wire [31:0] sum;

wire cout;

adder32 blockl(a, b, cin, CLOCK, sum, cout);

/lcreate a clock with a cycle of 100ns
initial

begin

CLOCK = 1'h0;

forever #50 CLOCK= ~CLOCK;
end

initial
begin
cin=1'bl;
a = 32'h0000;
b = 32'h0000;
$display("%d a=%h b+%h cin+%h sum+%h cout+%h", $time, a, b, cin, sum, cout);
#100 a = 32'h00000000;
b = 32'h0000ffff;
$display("%d a=%h b+%h cin+%h sum+%h cout+%h", $time, a, b, cin, sum, cout);
#100 a = 32'h0000ffff;
b = 32'h00000000;
$display("%d a=%h b+%h cin+%h sum+%h cout+%h", $time, a, b, cin, sum, cout);
#100 a = 32'h000Offff;
b = 32'h0000ffff;
$display("%d a=%h b+%h cin+%h sum+%h cout+%h", $time, a, b, cin, sum, cout);
#100 a = 32'h00000000;
b = 32'hffff0000;
$display("%d a=%h b+%h cin+%h sum+%h cout+%h", $time, a, b, cin, sum, cout);
#100 a = 32'hffff0000;
b = 32'h00000000;
$display("%d a=%h b+%h cin+%h sum+%h cout+%h", $time, a, b, cin, sum, cout);
#100 a = 32'h000Offff;
b = 32'hffffffff;
$display("%d a=%h b+%h cin+%h sum+%h cout+%h", $time, a, b, cin, sum, cout);
#100 a = 32'hffffffff;
b = 32'hffffffff;
$display("%d a=%h b+%h cin+%h sum+%h cout+%h", $time, a, b, cin, sum, cout);
#100 a = 32'h00000000;
b = 32'h00000000;
$display("%d a=%h b+%h cin+%h sum+%h cout+%h", $time, a, b, cin, sum, cout);
end

[[finish the simulation at time 1000ns
initial

begin

#10000 $finish;

end
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Starting NCLaunch

Start NCLaunch with the following command in the directory ~/project/rtl_verilog where
the source files are placed.

% nclaunch —new&

where —new specifies that this is a new design. The command nclaunch should be used if
it is not a new design. At startup, NCLaunch displays a list of modes which users can
choose, as shown in figure 3-1.

Click on Multiple Step.

As this is a new design, user must define a cds.lib and work library. NCLaunch opens the
Set Design Directory form as figure 3-6. Do step 3 if the Set Design Directory form
doesn’t appear, otherwise skip step 3.

Choose File=>Set Design Directory... from Nclaunch main window as shown in figure
3-5. The Set Design Directory form appears as shown in figure 3-6.

—| NCLaunch : fhome/staff/elezhg/project/rtl_verilog | - | |
File Edit Tools Utilities FPlug-Ins Help

Filters:{*.w “.vhd *vhdl :i

nelaunch=

[ 0items selected

Figure 3-5 NCLaunch main window.

= Set Design Directory

— Design Directory

— Library Mapping Fila

| |

Create cds.lib File... I

— Work Library

| =] [V |

- Ok | Cancell Help |

Figure 3-6 Set Design Directory form.
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4. On the Set Design Directory form, click on the Create cds.lib File button under the
Library Mapping File field.This opens the Create a cds.lib file form as shown below.

—| Create a cds.lib file |

Directory:  fhomesstafffelezho/8SIC/ASIC datassim/tl_Yerilog ._-| |

I~ iz
File name: ;u:dsllh | ‘ Save I
Files oftype:  Library Files (".lik) " | Cancel | |

Figure 3-7 Create a cds.lib file form.

5. Click on Save to create a library mapping file with the default name - cds.lib. NCLaunch
opens the New cds.lib File form, as shown in figure 3-8. This form lets user pick the
libraries that the user wants to use.

= For Verilog files, choose Don’t include any libraries.
= For VHDL and mixed-language designs, choose either the default libraries or
the IEEE pure libraries.

— New cds.lib File

Howy would you like to configure the cods.lib file?

% Include default libraries (vhdl or mixed design)
wr Include |EEE pure libraries {¢hdl or mi<ed design)
~ Dontinclude any libraries (verilog design)

< ‘ 9] | Cancel

Figure 3-8 New cds.lib File Form.

6. Click on OK to close the New cds.lib File form. NCLaunch displays the main window as
shown in figure 3-9.
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—| NCLaunch : /home/staff/elezhq/project/rtl_verilog | - | |
File  Edit Tools Utilities Plug-Ins Help

Ermygers:

|

Directory:;.n’homefstafr.n’elethfprojectfrtl_v | | Y Error Unable to-find an “hdlvar file
to load in.

e INCA_libs
R adderazy

4

3 worklin

bfie] Snapshots

Filters: . “vhd " whdl _vJ | . =
nclaunch=
0 items selected |

Figure 3-9 NCLaunch Main Window.
3.2.2 Compiling and Elaborating the Design

Before simulating the design, user must
e Compile the source files using the Verilog Compiler®, and
o Elaborate the design into a snapshot using the elaborator.
A snapshot is the representation of the design that the simulator uses. The NCLaunch main
window gives user access to the tools which user needs when compiling and elaborating design,
as well as to several utilities. User accesses the tools and utilities by using the Tools or Utilities
menu or clicking on the appropriate button on the toolbar®.

The steps of compiling and elaborating are introduced in the following sub-sections.
3.2.2.1 Compiling the Design
1. Select the Verilog files that make up the design: adder32.v and test_adder.v. To select
multiple files, hold down the control key and click on each filename.
2. Click on the Verilog Compiler button.
The 1/O area at the bottom of the window displays the ncvlog command that runs, and it
displays the messages that the compiler generates as it compiles the design files.

3.2.2.2 Elaborating the Design

To elaborate a design, user typically expands the work library (worklib), select the top-level
design unit, and then click on the Elaborate button.

® Use VHDL compiler if the source code is written in VHDL.
® Refer to section 3.1 for the Tools or Utilities or toolbar.
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=

Expand the work library (worklib) by clicking on the plus sign next to the hardhat icon.

2. Expand the top-level design unit. In this example, the top-level is the Verilog testbench,
test_adder.

3. Select the module.

4. Choose Tools=>Elaborator to open the Elaborate form which is shown in figure 3-10.

—-i Elaborate : |

Design Unit fworklib. test_adder module

{ [lib]cel[view] )

_1 Snapshot Mame

H Work Library |warklib |
Overyrite log file.  — | [ncelablog I
F -
W Errar Limit 15 -

1 Update if neaded

B Access Wisihility all — |

| Executable Filename | I

{ Default: ncelak |

_I Cther Options

Advanced Oplions... |

A O I Cancel Apply Help I

Figure 3-10 Elaborate Form.

Notice that the Access Visibility button is selected and that the value is set to All. This
option provides full access (read, write, and connectivity access) to simulation objects so
that user can probe objects and scopes to a simulation database and debug the design.
Enable the Other Options button and enter -timescale 1ns/1ns in the text field.
6. Click on Ok to elaborate the design.
The 1/O area at the bottom of the window displays the ncelab command that runs, and it
displays the messages that the elaborator generates.

o

3.2.3 Starting the Simulator
To start the simulator:
1. Expand the Snapshots folder to display the shapshots that are available in the design

library.
2. Select the snapshot, as shown in figure 3-11.



lEiIE Edit Tools Utilities  Plug-Ins Help
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Brovsers:

Tools:

| Di'rec:tnry:!'elethmSICfP.SIC_data.r’simml_w ﬂ B homedstafitelezhy/ASICIASIC, datassimer

pefp| =G, workiib
B[] INCA_libs S adderd?

5 adderaz.y g test_adder
L] test addery 58 module

=1 Snapshots

|Fitters:| " * whd *vhl

bud | =1 i |

Figure 3-11 Selecting the snapshot.

3. Click on the Simulator button.
The Design Browser and the Console window appear. User can access design hierarchy
in the Design Browser, and enter ‘SimVision and simulator’ commands in the Console

window.
= Design Browser 1 — Simvision | -]
File Edit ¥iew Select Egxplore Simulation  Windows Help
#5] - o m 5% “oBEDEYEE
5 ndTimef-‘«j =|0 wlins = A= | | Search Times: | Value /| ?
DRSS Simulation Time: 0 + 0 |
Brawse: I@ All Available Data »| €3 Signals/Wariables of scope: I R @]
=B simulator Signal/¥ariahle [Value |
. 2 E test adder .
Leaf Filter: |- - =3 B> [B® @ [ [m [Ae Fiter [ |
|®]

| 0 objects selected |

Figure 3-12 Design Browser.

= Console — SimVision |
Eile- Edit Simulation Windows Help
& i amx

D 5 5 | simulation Time: 0+ 0 R o oF

nesim=

Simvision_ simulator |

Figure 3-13 Console Window.

22
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In the Design Browser sidebar on the left side of the window, SimVision places the
simulation at the top of the hierarchy and assigns it the name simulator. The top-level of
the design hierarchy is placed below the simulator. In this example, it is named
test_adder.

At startup, the Console window has two tabs, as shown in figure 3-13. The SimVision
tab lets users enter SimVision commands and the simulator tab lets users enter simulator
commands. As simulation running, the Console window also displays messages from
SimVision and the simulator.

After invoking the simulator, user can exit NCLaunch’. To exit NCLaunch, bring the
NCLaunch main window to the foreground and choose File->Exit from the menu bar.

3.2.4 Simulating the Design

SimVision lets user choose the simulation data that user wants to save for particular objects
or scopes. This can help to keep the size of simulation data files as small as possible. At a later
time, user can load a simulation data file back into the Waveform window and re-examine the
simulation results.

This section describes how to select simulation data to save and how to run the simulation.

3.2.4.1 Selecting the Simulation Data® to Save

User can save simulation data by probing the design during simulation and saving the values
of the probed objects to a database. There are two types of probe commands:

Probe® a specific object or objects. The values of the specified objects are saved in the
database

Probe a scope or scopes. Users can choose the type of information to save, such as the
inputs to that scope, and can choose whether to probe some or all subscopes.

To probe all objects in all scopes, begin at the top module as follows.

1.

2.

In the Design Browser, click on the + icon next to top:test_adder to expand the
hierarchy.

Select the top scope. The signal list on the right side of the window displays the signals
for the top scope, as shown in figure 3-14. The signal list indicates the type of each signal
— input, output, inout, internal signal, or transaction. User can use the Leaf Filter to
choose signals which are intended to view.

" For more information about NCLaunch, user may refer to the NCLaunch User Guide.

8 User can create different simulation database for individual components of design to help debugging,
referring to “Managing Simulation Database” in the SimVision User Guide.

° About enabling, disabling, and deleting probes, or creating new probes, please refer to “Creating and
Managing Probes” in SimVision User Guide.
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= Design Browser 1 — Simvision

B
File Edit Yiew Select Explore Simulation Windows Help
T A Tor 3 -
FEET 2% oELBEVES
Y n1|Time.ﬂ._| =|D jlns fud | it S mp | Search Times:| Value er f%% §§
[ f it 1]l %’} :—};’ | @ | Simulation Time: 0+ 0
Browise: I@ all Availabla Data x| & signalsrvariables of scope: Isimulator::test_adder o
=8 simulator Signal/y ariahle [Vale |
...... T test adder ‘%; a |hireaseeoss
=By B P
ity *
CLOCK =
cout %
S "hacoeone

Leaf Filter. [* - [ B B (@ [ m B Rt |
®

‘1 object selected

Figure 3-14 Choosing the top scope.

3. Choose Simulation = Create

Probe... from the menu bar.

24

SimVision opens the Create Probe form. This form lets user probe one or more levels of
subscope, choose the type of signals that user wants to probe, and write the probed

information to any database.

= SimVision: Create Probe - [
Frobe Mame: | (optional)
¥ Delete afm Ao @ Browser ~
Probe these signals and scopes:
B test_adder X
A
Signal‘Scope: | Add

Within each scope, include:

= Scope

_1 Include sub-scopes:

_1 Include within each scope:

1 Add to wave

Store in database: | {defaulfy

form display

ok | Cancell Help |

Figure 3-15 Create Probe form.
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4. For this probe™:
e Select Include sub-scopes and choose all from the drop-down list to include all
the sub-scopes in the design.
e Select Include within each scope and choose all from the drop-down list to
include all inputs, outputs, and ports.
o Deselect Add to waveform display.
The form should have the settings shown in figure 3-16.

—| SimVision: Create Probe ==
Probe Mame: | ' (optional)
¥ Delete o Add @ Brinwser
Frobe these signals and scopes:
I test_adder I
-f.
Signalscope: | Add
Within each scope, include:
HE Scope W Include sub-scopes:
E-3E  Sub-scope |cag+ |
o -EE Al levels.. =
=8 (inputs) W Include within each scope:
CoER (outputs) [all~ '
FoER (inouts)
il finternals)
Storein database:!(default) :] ﬁi
1 Add o waveform display
- Ok I Cancel I Help I

Figure 3-16 Create Probe form.
5. Click on Ok to close the Create Probe form.
3.2.4.2 Running the Simulation

To run the simulation:

1. From the SimVision window, choose Simulation=>Run. SimVision simulates the design
and saves the simulation data in a default database. As it runs, the simulator displays the
following messages in the Console window.

19 There are other ways to create probe(s). Please refer to NC-Verilog Simulator Help for more information.
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= Console — SimVision |-
File- Edit Simulation Windows Help
DT 5 o | Simulation Time: 10,000ns + 0 & o oF
ncsims run X

0 2=00000000 b+00000000 cin+l sum+rooooooot coub+st

100 a=00000000 h+0000f££f cin+l sum+00000001 cout+0
200 a=0000£E£Ef h+00000000 cin+l sum+00010000 cout+0
300 ==0000£EEf h+0000££EE cin+l sum+00010000 cout+0
400 z=00000000 b+££EE0000 cin+l sum+000LEEEE cout+0
500 a=f££f£0000 b+00000000 cintl sum+EEEE0001 cout+0
600 a=0000£€£f h+fEEEEFEFE cin+l sum+fEFE000L cout+0
T00 a=fEEEEEFE h+fEEEEEEF cintl sum+0D000EFEEf couts+l
800 2=00000000 h+00000000 cin+l sum+EfEEEFEE cout+l

Simulation complete wia $finish{l) at time 10 US + 0

Cftest_adder w51 #10000 $finish;

ncsims

=~

SimYision  simulator I

Figure 3-17 Messages of Console window.
Note:

o After completed these steps, user’s working directory should contain a new directory
named waves.shm. The waves.shm directory should contain two files — waves.dsn
and waves.trn.

e To correct any problems if there was, restart the simulator by choosing
Simulation—>Reinvoke Simulator from the Console window.

3.2.5 Displaying Simulation Data™

Waveforms show the values of signals at any time during simulation. They can help user to

understand the behavior of the design. To open a waveform window:

e Deselect™ the top scope in the Design Browser sidebar, and then click on the Waveform
button in the Send to toolbar. User can deselect the scope by pressing Control while
clicking on the selected scope.

SimVision opens a blank Waveform window, as shown in figure 3-18.

1 For more information about managing Waveform window and displaying signals, refer to SimVision
User Guide.

12 If user selects a scope before clicking the Waveform button, all of the signals in that scope are added to
the Waveform window. If the scope has many signals, this may add more signals to the window, and it may
take a long time to load all of those signals and their waveforms into the window.
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— Waveform 1 — SimVision |- |]
File Edit Yiew Explore Format Simulation  Windows Help

~ | {r | s g | [EBC T g (= o) |
& o e x| Lt R FROREE
Search Mames: | Signal » | v @, &, Search Times:| Value -

Filmimea <[ =[tooo0 =f[ns -] ARA~ .
“ Baseline = 0 i

D) |0 abjects selected |

Figure 3-18 Opening a blank waveform window.

3.2.5.1 Selecting the Signals to Display

In the Design Browser sidebar, user can select objects from one scope at a time and send

them to the Waveform window.

To select the signals that user wants to display in the Waveform window:

1. Expand the Design Browser sidebar by clicking on the Expand ﬁ button in the

sidebar tab of Waveform window. SimVision adds the sidebar to the window, as shown

in figure 3-19.
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= Waveform 1 — SimVision E |J|

FEile  Edit Xiew Esxplore Format Simulation  Windows Help

[ [ : S 3 e |
&~ BBV
Search Mames:| Signal ~/ | -v @, & Search Times: | Value =

[ Timea =] = [10,000 ~l[ns =] B

s:?< *%@ M:%\I »TK<E‘>

@} ﬁl Simulation Time: 10,000ns + 0 | Time Range: [0 : z00C ]|

Elaselme =0

Cursor-Bageline = 10,000ns
Browse: | &l Available Data

: r s -; Options___ m & )
- Cursar =
B simulator Al

LoEE test adder

4

Leaf Filter: [ =~

Showe contents: | In the selector helow =

[ [ 8% [@ [& [ [ar Frer[ o

W Click and add to waveform area

@ ] Jects 58 ected

Figure 3-19 Expanding the design browser sidebar.

2. Expend the test_adder scope by clicking on the 3= button (If there are subscopes under
the top, clicking on the +button to expand design, and then select a scope.) The sidebar
displays the signals for that scope in the selector area, as shown in figure 3-20.

— Waveform 1 — SimVision ==
Eile  Edit Yiew Explore Format Simulation  Windows Help
#lo e x et/ $ ¢+ " OBOBYEE
Search Mames; | Signal -/ | - & Search Times: | Value v

EEZfimeA- =1 n {14 il) 51 Simulation Time: 10,000ns + 0 Titne Range:?ﬂ- ZDD'E_yTE;

l[ns = Jl'ﬁ' :

Elaselme =0
Cursor-Baseline = 10,000ns

Browse: rI(; r’-\li Availa.ble.Daia vi Options..

=¥ simulator

o2 B test_adder

Cursar =

Figure 3-20 Showing the contents of the slected scope.

Leaf Filter: |* -

Shows contents: | In the selector below =
o Epb dfbcin G CLOCK  dEh cout g sum
i ot

[ [ [ [ 60 (57 Fierlf -

W Click and add fo wavefotm area

3. Inthe selector area, select the signals that user wants to add to the Waveform window.
For this example select all the signals.
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4. Collapse the sidebar by clicking on the Collapse Efibutton.
The Waveform window displays the signals and waveforms, as shown in figure 3-21.
Signal names and values are displayed on the left; their waveforms are displayed on the

right.
I Waveform 1 — SimVision i
Eile- Edit Miew Esplore Format Simulation  Windows Help
| T [ e e g 88T " dTor I
Floo]snmxent B $ + “eEBYEE
Search Mames: | Signal = | x| @& @, Search Times:| Value = i%% %
[/ Times = =[10,000 =l[ns =] o | "M MW [ Simulation Time: 10,000ns + 0 | Time Range: [0 2000ns - ¥

x@ Baseline = 0
Cursor-Baseline = 10,000ns

| Cursar =

4000 5000 G000 7000 G000 1

|@i \D ohjacts selected

Figure 3-21 Displaying Data in the waveform window.

Note: SimVision adds the signals in the order in which user selects them, but user can
rearrange them. Select the signal that user wants to move, and then press and hold the middle
mouse button. As moving the cursor, SimVision displays a red insertion bar. Place the
insertion bar where the user wants the signal to appear, and release the mouse button.

3.2.5.2 Moving through Simulation Time

Above the waveform data, user can see the beginning and ending times for the simulation data
currently displayed. Below the waveform data, the scroll bar shows the entire simulation time.

User can adjust the amount of waveform data displayed in the window by entering a new time
range.

To enter a new time range:

1. For this example, enter 0:1000ns, as shown in figure 3-22, and press Return to apply the
time range.

Tite Range: |0 : 1000ns fd

Figure 3-22 Entering a new time range.

2. Save these settings by selecting Keep this range from the Time drop-down menu as
shown in figure 3-22, to keep the time range.

3. Atany time, user can quickly return to the view by selecting it from the drop-down list.
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3.2.5.3 Moving the Cursors

The Waveform window contains two cursors, named TimeA and Baseline. User can move
these cursors to any point in simulation time and use them as reference points. User can also
create any number of additional cursors. However, for this example, user needs only these two.

To move a cursor:

o Either dragging the cursor to the desired time or entering a simulation time in the cursor
time text field. For this example, change the simulation time of TimeA to 800ns, as
shown in figure 3-23.

nzﬁime.ﬂ\ - =§'§DD =||ns =|

Figure 3-23 Setting the cursor time.

3.3 Debugging a Design

After analyzing the waveform data, user is able to know if it is correct. If an error happens,
debugging the design is needed. Normally 4 steps have to be done to debug a design:

e Search for conditions;

e Analyze the waveform data;

e Locate an error;

e Correct source code.

The debugging method is described below. The example used is the adder32, too. The
following description serves demonstration purpose only, as there is no error with the adder32
RTL code.

3.3.1 Searching for Conditions

A condition is a combination of signal values that user wants to search for in the Waveform
window. For example, a condition that occurs whenever cout and CLOCK have the value 1, as
follows:

1. Select the signals of the cout and CLOCK in the Waveform window and click on the
Next Edge button until both signals have value 1.

2. Choose Edit > Create - Condition. SimVision opens the Expression Calculator, as
shown in figure 3-24.
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Figure 3-24 Expression Calculator.

The Expression Calculator creates a default AND expression. This expression is true
whenever both signals have the value 1. User can edit the expression if a different
condition is to be investigated.

Enter a name for the condition expression in the Name field such as cout_and_CLOCK.
Click on the Waveform button to add the condition to the Waveform window. It can be
treated as a normal signal when a condition is added to the Waveform window.

Choose File->Close Window to close the Expression Calculator on the Expression
Calculator window.

Search for the expression to locate where the condition occurs on the Waveform
window.

Analyzing Simulation Data in the Waveform Window

Analyzing waveform can help user to find problems in a design. For example:

1.

w

Set the simulation time to 800ns, as shown in section 3.2.5. There are a few ways to set
the simulation time:

= Enter the desired time in the cursor time field.

» Drag the primary cursor until it reaches the desired time.

= Select the signal to be viewed and click on the Next Edge button until it reaches

the desired time.

Select a condition to be investigated and click on the Next Edge button to follow the
sequence of events from clock cycle to clock cycle.
Locate the error while clicking on the Next Edge.
From the Time field, choose Keep this View from the drop-down list so that it is easy to
go back to this view later.
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3.3.3 Analyzing Simulation Data in the Register Window

Another way to analyze simulation results is through the Register window, where user can
create custom views of the simulation data, including freeform text and graphical elements. A
Register window can have several pages, each with its own view.

To create a page in a Register window:

1. From the Waveform window, select the signals to be analyzed, such as the a, b, cin, cout,
CLOCK and sum.

2. Click on the Register W button to send these signals to a Register window, as shown

in figure 3-25.
— Register 1 — SimVision =
File- Edit Wiew Explore- Format Page Simulation Windows Help
Pt S| o x| b % m x $ + " aBENBYES
Y r [Timea | =!§50 :’sn?:_bl}aﬂ- 1_«__zr_| Search Times _Va\ue - : ??z 2

@ | Simulation Time: 10,000ns +.0

"E ohjects selected I

Figure 3-25 Adding signals to a Register window.

Along the right side of the window are buttons that let user draw graphical objects, add
text, and manage the layout of the objects in the window. Tool tips pop up when placing
the cursor over these buttons, telling user what functions they perform.

3. Arrange the objects any way that user likes. For example, the layout in figure 3-26 shows
the relationship between the inputs and outputs.
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Figure 3-26 A custom layout.

Enter a simulation time, such as 600ns in the Cursor TimeA field. The Register window
updates the signals to show the respective values at that time.

=2

Select a signal, such as cout and click on the Next Edge —=T button. The time progresses
to the next edge of that signal and the Register window updates all of the signals to show

the values at that time.
Click on the Previous Edge 11 button to move the simulation time back to the previous

edge of the selected signal.

Fixing an Error in the Source Code

User can use the Signal Flow Browser and Source Browser to locate the line in the source
file where an error occurs.

1.

In the Waveform window, select the variable or signal, cout, and choose Explore>Go
To-> Cause. The Signal Flow Browser shows the signal user selected and the list of the
signal’s drivers, as shown in figure 3-27.
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Figure 3-27 Displaying drivers in the Signal Flow Browser.

2. Open Source Browser by clicking on Windows—>New->Source Browser.
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3. From the Signal Flow Browser window, select the first driver. The Source Browser now
points to the line in the source file where the first driver is set to, as shown in figure 3-28.

—| source Browser 3 — SimVision [.../ASIC_data/sim/rtl_vetilog/adder32y] | - | |
File Edit Wiew Select Format Simulation  Windows Help

F| & #l § ToEPBRYEE
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2 Etest adder

;M;- Scope:

~| %5 Files: |fhomerstafrfe|ethr...ﬂest_adder.v [1:54] = G

PR et

i

4

fif1le: 1log/faddecid v
module adder32 {a, b, cin, CLOCKE, =sum, cout);
1nput [31:0] = b;

input ¢in, CLOCK;

output [31:0] sum;

output couk;

reg [31:0] sum;

reg cout;

reg [32:0] temp;

always Bfa or b or cin)

begin

temp=a+h+cing

end

FTEl et

always E(posedge CLOCE)
hegin
Acout, sum}d=temp[32:0];

| tend

endnodiule

1 @|Navigate scopes in design: simulator:test_adder

0 ohjects selected ||

Figure 3-28 Displaying source code in the source Browser.

4. To fix an error in the design, choose Edit->Edit File from the Source Browser and

make the necessary changes.
5. Save these changes to the source file.
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6. Choose Simulation->Reinvoke Simulator from the Source browser. if the Reinvoke

dialog box appears, click on Yes.

SimVision compiles and elaborates the design, and restarts the simulator. All of the

SimVision windows that were opened in the previous session are opened again.

In any SimVision window, choose Simulation->Run to generate new simulation data.

8. In the Waveform window, display the view previously saved. It can be seen that the
result is correct now.

~

3.3.5 Ending a SimVision Session
To exit SimVision:
1. Choose File=>Exit SimVision from any SimVision window.
2. If the Waveform window remains open, choose File->Exit SimVision from the

Waveform window. SimVision displays a confirmation message.
3. Click on Yes to exit and close all SimVision windows.

3.4 Conclusion
In this chapter, the usage of NCLaunch is described. User can follow the steps listed in
section 3.2 to compile, elaborate and simulate a design. If the results of design were incorrect,

user can follow section 3.3 to debug the design and locate errors, and then re-run the design.

Next, the design can be brought to synopsys chip synthesis for synthesis and optimization.
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4. Logic Synthesis and Optimization Using Synopsys Chip
Synthesis (Design Compiler)

Synthesis is the transformation of an idea modeled with RTL code into a manufacturable
device to carry out an intended function. Optimization means to compile a design with the design
constraint file which is a description file of design specifications. If user has a design modeled
with RTL code, either Verilog or VHDL, and the code has been verified with the NCLaunch
previously described, it is time to use the tool - chip synthesis to synthesize and optimize the
design and to get a gate level netlist of the design. The usage of chip synthesis is described in this
chapter.

The arrangement of this chapter is as follows. The introduction to synthesis and optimization
is presented in section 4.1. The preparations for using design compiler (DC) are described in
section 4.2. Methods to fix violations are listed in section 4.3. A tutorial of using DC is shown in
section 4.4. Lastly, conclusion is given in section 4.5.

4.1 Introduction to Synthesis and Optimization

Figure 4-1 shows the synthesis and optimization flow using DC, and figure 4-2 shows the
project directory structure correspondingly to figure 4-1. Synthesis and optimization is an
iteration process. As figure 4-1 shows, user needs to do the followings to finish an iteration of
synthesis and optimization.

= Edita.synopsys_dc.setup file — a set up file for DC.

= Edita constraint file — a file including design specifications.

= Synthesize and optimize a design with the constraints.

=  Generate and check reports to ensure that it meets the design target or specifications.
After each iteration, user needs to decide whether modifying constraint file or RTL code by

checking the reports if the design result is not satisfactory, referring to figure 4-1.
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Prepare .synopsys_dc.sctup file
and save it in project directory

Prepare Constraint file according to the design
specifications and save it in .scripts/constraints.scr

r

Invoke DC (=« Modify RTL code

Y

—*| Modify RTL code

[ Y

r
Read design from .source/verilog/
design.v or .source/VHDL /design.hdl

r
Save the design in .unmapped/design.db

I

Constrain the design with
.scripts/constraints.scr

y
Compile Modify constraint file

v

[

Generate a constraint report
and save it in .reports/

No
Generate timing report
and save it in .reports/

Modify constraint file

Big violation ?

Save design in .mapped/design.db or
mapped_design.v

Figure 4-1 Synthesis and optimization flow.

Project directory/

source/ unmapped/ scripts/  mapped/  reports/
verilog/ vhdl/

Figure 4-2 Project directory structure.
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4.2 Preparations for Using Design Compiler

To use DC, user must know the followings.

= The prescriptions of the .synopsys_dc.setup file.
= The prescriptions of the constraint file.

= How to synthesize and optimize a design.

= How to generate and check reports.

These are described in this section. User has to understand them in order to synthesis and
optimize design.

4.2.1 Prescriptions of the .synopsys_dc.setup File

The .synopsys_dc.setup consists of four basic commands as shown in table 4-1, where there
are four variables: target library, link library, symbol library and search path. The definitions of
the variables are as follows.

= target_library - the library used by DC for building a circuit.

= link_library — the library used to resolve netlist leaf-cells and sub-design references.
= symbol_library — defining the symbol library used by DC.

= search_path - defining the path where DC will search.

These variables are reserved for DC. During mapping, DC will choose functionally-correct
gates from target library and calculate the timing of the circuit using vendor-supplied timing data
for these gates. Referring to the second command of table 4-1, * represents DC memory. During
link, DC searches the memory first and then reads the library files specified by the link_library
variable, and DC also searches all UNIX directories defined by the search_path variable.

Table 4-1 .synopsys_dc.setup file.

set target_library “tech_library.db”
set link_library “* tech_library.db”
set symbol library  “tech_library.sdb”
set search_path “$search_path ./Junmapped”

4.2.2 Prescriptions of Constraint File

In order to obtain optimum results from DC, designers have to methodically constrain their
designs by describing the design environment, target objectives and design rules. The constraint
file may contain timing and /or area information, usually derived from design specifications. DC
uses these constraints to perform synthesis and tries to optimize the design with the aim of
meeting target objectives.

The constraint file contains the considerations of three aspects:
= Timing Goals;
= Environmental Attributes;
= Design rules and area requirement.
These are briefly explained below.
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4.2.2.1 Timing Goals

Timing goals define the timing constraints for all paths within a design, which include all
input logic paths, the internal (register to register) paths, and all output paths with respect to
clock. The categories and the relative commands are shown in figure 4-3. The usage and
definitions of some of the commands are given below, and others can be found in DC document.

create_clock defines clock source and clock period.

Format: create_clock™ —period value_in_time(ns) [get-ports port-name]
set_dont_touch_network tells DC not to “buffer up” the clock net, even when the
flip-flops load to high.

Format: set_dont_touch_network [get-ports port-name]
set_clock_uncertainty™* models clock skew which is defined as the delay difference
between the clock network branches. Figure 4-4 shows the clock skew which is
labeled as Tu.

Format: set_clock _uncertainty —setup Tu_in_time (ns) [get_clocks clock-name]
set_input_delay constrains input paths.

Format: set_input_delay —max or -min value_in_time(ns) —clock reference-clock-

name [get_ports ports-name]
set_output_delay defines the time it takes from the data to be available before the
clock edge.

Format: set_output_delay —-max or -min value_in_time(ns) —clock reference-

clcok-name [get_ports output-port-name]

Define input arrival Model transition Defines output timing
time relative to clock delay on clock source requirements
set_input delay set_clock transition set_output delay

\\\\\\\\3k g
Model skew on R
clock source \ =

set_clock uncertainty i SR

Define clock source
create clock
set_dont touch network \\

| Exceptions to single-cycle |
| behavior: |
| set_false path i
|set_mu1ticycle_path

set clock latency -source

Define clock network
set_clock latency

Figure 4-3 Timing goals.

3 For multiple synchronous clocks, the format is as same as that of single clock. User may refer to DC
document for more information.
1t also defines hold time requirements, referring to DC document for more information.
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Figure 4-4 Diagram of clock skew - Tu.

4.2.2.2 Environmental Attributes

The environmental attributes define I/O port attributes and wire load models of a design,
referring to figure 4-5. The definitions of the commands are given below.

» set_load specifies a load capacitance value on an output port.
Format: set_load value™ [get_ports output-port-name]
= set_driving_cell specifies a realistic external cell driving the input ports.
Format: set_driving_cell —lib_cell cell-name —pin pin-name [get_ports port-
name]
= set_wire_load_model™ specifies wire load model used for gate connection in DC.
Format: set_wire_load_model —name wire-name*’
= set wire_load_mode specifies what wire load mode to use for nets that cross
hierarchical boundaries.
Format: set_wire_load_mode enclosed® (or top)
= set_operating_conditions specifies the synthesis operating condition™: worst,
normal, and best.
Format: set_operating_condition —-max WORST (or —min BEST or both) —library
library-name

set operating conditions

=

set driving cell
set _max capacitance —

set load

IIII:—|
o—]

. F T

set_wire load model

ol T

H
Yy

Figure 4-5 Environmental attributes.

'3 The unit of capacitance is pF.

16 A wire load model is an estimate of a net’s RC parasitics based on the net’s fanout, supplied by vendor.
7 User can use ‘report_lib lib-name’ to list the available wire load model.

18 Use enclosed for sub block level connection and top for top level connection.

19 User can use ‘report_lib lib-name’ to list the vendor-supplied operating conditions.
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4.2.2.3 Design Rules and Area Constraints - Optional

Vendors impose design rules that restrict how many cells are connected to one another based
on capacitance, transition and fanout. User may apply more conservative design rules to
anticipate the interface environment and prevent the design from operating cells close to their
limits, where performance degrades rapidly. DC respects design rules as highest priority of all on
the following order: max_capacitance, max_transition, and max_fanout. The commands to
restrict them are

e set_max_capacitance,
e set_max_transition, and
e set_max_fanout.

User can also specify area goal for a design by the command: set_max_area area-value. User
may refer to DC reference for more information about these commands.
4.2.3 Synthesizing and Optimizing a Design

Table 4-2 shows the commands which are used to synthesize and optimize a normal design,
and Table 4-3 is that for design with hierarchy. What user needs to do is simply following either
table 4-2 or table 4-3 to synthesize and optimize a design. A tutorial using these commands will

be given in section 4.4.

Table 4-2 Commands for a simple design.

read_vhdl my-design.vhdl # read_verilog for verilog code

write —format db —hierarchy —output .unmapped/my-design.db  # -format vhdl or verilog

link # link design

source .script/constraints.scr # constrain the design

compile® -scan # test ready compile

report_constraint” —all_violators # report all violation: design rule,
setup, hold and area.

report_timing® # report the worst timing path

write —format db —hierarchy —output .mapped/my-design.db # save final output

Table 4-3 Commands for a hierarchical design.

read_vhdl my-design.vhdl # read_verilog for verilog code.

write —format db —hierarchy —output .unmapped/my-design.db  # -format vhdl or verilog .

link # link design.

uniquify # remove multiple instantiations.

source .script/constraints.scr # constrain the design.

compile -scan # test ready compile.

report_constraint —all_violators # report all violation: design rule,
setup, hold and area.

report_timing # report worst timing path.

write —format db —hierarchy —output .mapped/my-design.db # save final output

20.21.22 There are other options, referring to DC document for details.
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4.2.4 Generating and Checking Reports

User needs to generate reports and check the reports to see if there is any violation. There are
two types of reports: report constraints and report timing. These are briefly described as follows.

4.2.4.1 Report Constraints

Constraint report shows all constraints which have been violated in a design. The violations
include design rules, setup, hold and area. The command to use is report_constraint —
all_violators. Table 4-4 is an example of part of the report. There are also other options. User
may refer to DC document for other options and usage.

Table 4-4 Reporting design rule violation.

dc_shell-t> report constraint -all violators

max_transition

Required Actual
Net Transition Transition Slack
I_PRGRM_CNT/nl84 0.50 0.69 -0.19% (VIOLATED)
I_PRGRM DECODE/n945 0.50 0.63 -0.13 (VIOLATED)
Ld_Rtn Addr 0.50 0.61 -0.11 (VIOLATED)
max_capacitance

Required Actual
Net Capacitance Capacitance Slack
CurrentState[0] 0.20 0.24 -0.04 (VIOLATED)
PC[O] 0.20 0.24 -0.04 (VIOLATED)
CurrentState[1] 0.20 0.24 -0.04 (VIOLATED)

4.2.4.2 Report Timing

Report timing shows path delay and each individual contribution to the path. The command to
use is report_timing. The command allows user to access Synopsys DesignTime, and it will do
the followings.

= The design is broken down into individual timing paths.

= Each timing path is timed out twice: once for a rising edge endpoint and once for a
falling edge endpoint.

= The critical path (worst violator) for each clock group is found.

= Atiming report for each clock group is echoed to the screen or a file directed by user.

A DesignTime timing report has four major sections: path information section, path delay
section, path required section and summary section. Table 4-5, figures 4-6, 4-7 and 4-8 are the
examples of the four major sections of a timing report. By checking the report, user is able to
know if the design passes the timing goals.
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Table 4-5 Path information section.

g et ek e ek b e b e e e e e e e e b ke ek e b e e b b e e b
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Figure 4-6 Path delay section.
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Point Incr Path
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Figure 4-7 Path required section.
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data required time 4.81

data arrival time -1.61

slack (MET) 3.20
o

) Timing margin (slack): negative
Either (MET) or (VIOLATED) indicates constraint violation
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Stk ) e
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Figure 4-8 Summary section.

The command: report_timing has two options which are often used, -delay max and —delay
min. The report_timing —delay max reports the worst timing path of each path group for setup®
time constraints. The report_timing —delay min reports the worst timing path of each path group
for hold®* time constraints.

4.3 Methods to Fix Violations

The common methods to fix violations are
= Check and modify the constraints,
= Check the design partition,
= Re-compile using a higher effort for small violations, and
= Modify the RTL source code.

In a nutshell, there are two types of violations: design rule and timing. The methods to fix
each type of violations are presented in the following sub-sections respectively.

4.3.1 Fix Design Rule Violation

Design rule violations may cause timing violations. User can use the commands
= report_net —connections —verbose and
= report_timing —net (for fanout)
to get more information of the design, and then decide if there is a need to use design rule
constraints to constrain the design.

If the violations are not big, user may use the command
= compile —scan —incr —only_design_rule
to fix them. Executing this command, DC only adds buffers or re-size cells. It fixes only design
rule violations and may fix hold time violations.

2% Refer to figure 6-1 of chapter 6 for setup time definition.
# Refer to figure 6-2 of chapter 6 for hold time definition.
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4.3.2 Fix Timing Violations

To fix timing violations, user can use the command
= compile —scan —inc —map high.
During the process, DC only accepts solutions that reduce critical path slack. The design will
most likely get better or stay the same.

A successive compilation will probably not help, unless user changes something like
constraints and/or structure of code, and then use the above command.

4.3.3 Other Options

A successful compilation needs skills and a well structured and partitioned design code.
Besides going back to check constraints and source code, other algorithms allow user to fix the
violations if the violations are not big. The options are

= creating custom path groups to allow more control over optimization, and
= using compile_ultra: the full strength of DC in a single command.
As for how to use them, user may refer to DC document.

4.4 Tutorial of Using Design Compiler

The tutorial uses the design - adder32 whose code has passed the verification in last chapter.
Following the tutorial, user is able to know how to use DC and how to synthesize and optimize a
design.

4.4.1 Preparations
1. Creating directories accordingly to figure 4-2 under project directory

2. Creating the setup file as below and save it as .synopsys_dc.setup in the project
directory.

set symbol_library "c35_CORELIB.sdb ¢35_IOLIB_3B_4M.sdb*"

set target_library "c35_CORELIB.db ¢35_IOLIB_3B_4M.db*®"

set link_library "* ¢35_CORELIB.db c35_IOLIB_3B_4M.db*™"

set search_path ". /design_kits_installation_directory/synopsys/c35_3.3V \
/synopsys_chip_synthesis_installation_directory/libraries/syn \
/synopsys_chip_synthesis_installation_directory /dw/sim_ver\
/synopsys_chip_synthesis_installation_directory /dw\

Junmapped ./work"

define_design_lib WORK -path ./work #optional but it is best to set it.

3. Creating the constraint file as below and save it as adder32_dc_constr.scr in the script
directory.

22627 The |OLIB library ought to be omitted if 10 cells are not required during synthesis.
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current_design adder32
reset_design
create_clock -per 100 -name clk [get_ports CLOCK]

set_dont_touch_network [get_ports CLOCK]
set_clock_uncertainty -setup 0.3 [get_ports CLOCK]
set_clock_uncertainty -hold 0.3 [get_ports CLOCK]

set_operating_conditions -lib ¢35_CORELIB.db:c35_CORELIB -max WORST
set_wire_load_model -lib c35_CORELIB.db:c35 CORELIB -name 10k
set_wire_load_mode enclosed

set_input_delay -max 2 -clock clk [all_inputs]

set_input_delay -min 0.4 -clock clk [all_inputs]

remove_input_delay [get_ports CLOCK]

set_driving_cell -library ¢c35_CORELIB.db:c35_CORELIB -cell BUF8 [all_inputs]
remove_driving_cell [get_ports CLOCK]

set_output_delay -max 0 -clock clk [all_outputs]
set_output_delay -min 0 -clock clk [all_outputs]

set load 0.1 [all_outputs]

4.4.2 Synthesizing and Optimizing a Design
User can follow the steps listed in this section to synthesize and optimize a design.
4.4.2.1 Read and Link Design
1. Invoke DC by type design_vision in the project directory. The Design Vision window

appears as shown in figure 4-9.
% design_vision
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Cells (Higrarchical)

Ialng’ g’u. preerances Erom File omesaahq.sy'nopsys__pr.es'l
design_vision-t> qui_start
design vision-t>

Figure 4-9 Design vision window.

There are three main parts on the window.
= the first part : pull down menu, toolbar and Hier.1 window;
= the second part: log (history and error/message) window;
= last part: command field. Users can type command here instead of using the pull
down menu.

2. On Design Vision window, click on File->Setup... to check the settings. For this
example, figure 4-10 shows the current settings.

Zheng Huan Gun
Varighles bl

| 200406501 st homestatielezhgASICaynthesisivark

* c35_CORELIB.dh c35_|OLIB_3B_4Mdb
c35_COPELIB.db c235_|OLIB_3B_4Mdh

c35_CORELI B.sch c3 al OLIB__.S B_% M sclh

—size infinite.

Figure 4-10 Design settings.
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3. On Design Vision window, click on File->Read... to read a design. The Read Designs
window appears as shown in figure 4-11.

|

Read Designs |

Look in: | ) homestatiele zhgid sl Chynthesisd j gj 28 ==
E.

ks

| mrapped

|_Jreports

s cripts

_Junmapped

_dwerilog

| work

File name: |

Oaen
File fype: | Database Files (.o * gob * sdb * podb * edif* egn *.fnc*.ls;! ‘Cancsl |

= Format: I Auto

=  synopsys:
4

Figure 4-11 Read Designs window.

Note: the command ‘read_file...”in the log window.

4. On the Read Designs window, click on verilog folder (where source code is saved) and
choose adder32.v.

—| Read Designs |

Lockin: |3 /homesstafiislezhg/ASIClynthesisterilog! =] | g_l o =

.
B a3z

Filz narme: I"adderSE.v" Open

File fype: I Database Files (*.db* gdb * =db * ook * edif* egn *.fnc*.lsil Cancel |

5 Format: | Auto

x| synopsys
4

Figure 4-12 Read source code.

5. Then click on Open on Read Designs window. The design is read in as shown in

figure 4-13. You will see an icon labeled adder... in the Hier.1 window under the
heading Logical Hierarchy.
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Cells (Higrarchical)

Gell Marre

[Retrame  [ellPath

4

| Register Name | Type | Vidth | Bus | ME | &R | A8 | SR | 55 | 5T | =

| sum_regq | Flip-flep | 32 | Y |N |N |N |N |N |N |

| cout_reg | Flip-flop | I | ¥ |¥ |H |H |H |H |0 | B
||

Presto compilation completed successfully. -

4 | b

Log History IErmrseWafme&I

deeugn vision-t= I

Figure 4-13 Design Vision window with the design - adder32.

The design adder32 is now in Design Compiler memory in terms of GTECH (synopsys

library) components.
On Design Vision window,

click on File=>Link Design... from pull down menu. The

Link Design window appears as shown in figure 4-14.

=

Searchpath: | 200406sp1 i homeistafiislezhoASI Csynthesistvark |

Browse..

Lirk librany: [ c35_CORELIB b c35_IOLIB_3B_4W oo
v Search merony first

[ | caneel | meey |

Figure 4-14 Link Design window.

Click on Ok on the Link Design window. The design is linked and the messages appear

in the log window, as shown

in figure 4-15.

design_vision—t> link
Linking design ‘adder3Z’
* (1 designs)

c35_CGORELIE (library)
c35_IOLIE_3B_4M (library)

A

a

Using the following designs and libraries:

Jhome fstaff felezhg/ASIC /synthesis/verilog/adder32. db

Japp2l/BMS 3. 60 _COS_F/synopsys/c35_3. 3V/c35_CORELIE. d
Fapp2l/8MS 3. 60 COS_F/synopsys/c35 3. 3%/c35 _IOLIE 3B
o
»

Log [Histary | Evarsmiarnings |

Figure 4-15 Link design message.
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8. Click on the icon labeled adder... in the Hier.1 window. Two yellow icons will appear in
the toolbar of Design Vision window & 1F|

9. Push into the “Symbol View” by clicking on the LE icon. A block with input and output
ports attached to it appears in the symbol view window. This is referred to as the symbol
view of the design. The symbol view shows the block diagram of the design.

B Syrrboli adder32

Figure 4-16 Symbol view of the design.

10. Push into the Schematic View by clicking on the ‘“I* icon. Designer can check if this is
similar to what is expected from the RTL code.

» Schematic.l adderd?

Figure 4-17 Schematic view of the design.

11. Zoom in to view the schematic by clicking on the ® icon.

12. Save the design in ./Junmapped/adder32_unmapped.db by clicking on File>Save As....
The Save Design As window appears as shown in figure 4-18.
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~i Save Design As | |

Loak in: I A homesrfielezhgASICEynthesis,

libs
_mapped
|_lIrzports
[scripts
_Junmapped
_verilog
ek

-
File fyoe: | Database Files (*.db* gdb * sdb * podb * edif* eqn * fic? .Ie:;l Cancel l
Eormat: | Auto = synoesys'

v Zavealldesigns in hiermarchy

4

Figure 4-18 Save Design As window.

Note the command ‘write ...” in the log window.
13. Click on the unmapped folder and type the name adder32_unmapped in the file name
field. Then click on Save. Note the command in the log window.

4.4.2.2 Constraining Design

Just proceed to step 1 if it is continuing from section 4.4.2.1. Otherwise, start DC with
command: design_vision, read the design- adder32_unmapped.db from the unmapped folder and
then link the design by clicking on File>Link Design....

1. To constrain a design, click on File>Execute script.... The Execute Script File
window appears as shown in figure 4-19.



2. Click on the folder where the constraints saved and click on the constraint file name.
Then click on Open. The messages appear in the log window which is shown in figure 4-

20.
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— Execute Script File

Loskire [/ 3 homestfislzhgASICEynthesis! = Eledf= =

£ g

| libs

1 rapped
| reports
_scripts

| unrmapped
] werilog
_1work

File nare: | .Cfpen

File fyoe: | Seript Files (* script*.scr®dos *.doy *.de® con ® ol * 4el) :l Cancel |

[ Echo cormmands

I Wetose

Figure 4-19 Execute Script File window.

Note:

design vision-t> uplevel #0 source /home/staff/elezhq/ASIC/synthesis/scripts/adderd?_de_constr.scr
Gurrent design iz ‘adder32’.
Resetting current design ‘adder32
Using operating conditions *WORST' found in library ‘c35 CORELIB’.
Design adderd2: Using wire load model *10k’ found in library ‘35 CORELIB'.
Varning: Design rule attributes from the driving cell will he

set on the port. (UID-401)

Log IHisb:r.y IErmr‘sﬂNarnings I

Figure 4-20 Messages of executing constraints.

4.4.2.3 Compiling a Design

1. Click on Design->Compile Design... on the Design Vision window. The Compile

Design window appears as shown in figure 4-21.

52

Ignore the warning messages as set_driving_cell requires specifying the output pin
name because this cell has only one output pin.

Note the command source.

Error messages appear in red color and warning in blue color.
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Figure 4-21 Compile Design window.

2. Click on Ok to start the compilation. Note the command Compile .... and the message
‘optimization complete’ in the log window. Note the change in Hier.1 window.

ELAPSED WORST WEG TOTAL NEG DESIGH N
TIME BREL ‘SLACK SLACKE  RULE COST ENDPOINT
0:00:21 249352 0.00 0.0 0.0
0:00:21 248352 0,00 0.0 0.0
0.00:21 24035 2 0,00 0.0 e
0:00:21  23734.0 0.o0 0.0 n.o

Optinization Complete

Transferring design ‘adder32’ to datshase ‘=dder32 unnapped.dh’

mrrent design is ’adder3g’.
Figure 4-22 Messages in log window.
;1.4.2.4 Generating Reports
1. Type the command ‘report_constraint —all_violators’ (or type ‘redirect

reports/viol.rpt {report_constraint -all_violators} to save the report’) in the
design_vision-t> field as shown in figure 4-23 and then enter.

r,eport_constra'int -all violators

Figure 4-23 Command to generate violation report.
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2. The violation report appears in the log window (or saved in the reports/viol.rpt) as shown
in figure 4-24.

design_visiun‘—b report_c:Jns train —all_violﬁtn s
Information: Updating design information. .. (UID-BE)

Report © constraint
-all wviolators
Design : adderd?
Version: V-2004.06-5P1
Date : Wed Sep 7 14:00:10 2005

This design has no viclated constraints.

1
Figure 4-24 Constraint report.

Note: if there was violation, fix them at this stage.

3. Type the command ‘report_timing’ (or type ‘redirect reports/timing.rpt
{report_timing}’ to save the timing report) in the design_vision-t> field as shown in
figure 4-25 and then enter.

Log [Histary IErmrSWarnings I
tlesign.vision-tx Ireport_timing

Figure 4-25 Command to generate timing report.

4. The timing report appears in the log window (or saved in reports/timing.rpt) as shown in
figure 4-26.

ClLlLl_J._J.UULa_CI.I_\.Ll_J. e UJ._ puLjrapury u § VAL TS o= LT L
add_1_root_add 12 201 26/C0 (ADD3Z) 0.64 19.34 £
add_1 root_=add 12 2,41 27/C0 (ADD3Z) 0. 64 19 .98 f
add_1 root add 12 2/01 Z8/C0 (ADD3Z) 0. 64 20 62 f
add_1 root add 12 2/01 29/C0 (ADD3Z) 064 21.26 f
add_1 root add 12 2/01 30/C0 (AaDD32) 0. 64 21.90 f
add_1_root_add 12 2,01 31/5 (ADD3Z) 0.81 22.71 ¢
add_1 root add 12 2/5UM[31] (addec3Z DWOl add 33 0) 0.o0 22:71 ¢
sum_req[31]/D (DFS3) 0.00 22,71 ¢
data arrival time 22.71
clock clk (rise edge) 100,00 100,00
clock network delay (ideal) 0.00 100,00
clock uncertainty -0, 30 9. 70
sum_reqg[31]/C (DFS3) 0.oo 9970 ¢
library setup time -0.27 99.43
data required time 99.43
data required time 09.43
data arriwal time -22. 71
slack (MET) 76, T3

Figure 4-26 Timing report.
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5. Save the design by clicking on File->Save AS... on the Design Vision window. Save it
as adder32_mapped.db and adder32_mapped.v under the folder mapped.
Note the command ‘write ...” in the log window.

6. Save the standard delay format (SDF) file by type write_sdf mapped/adder32.sdf in the
field of design_vision-t>. Check if there is a file named adder32.sdf under the mapped
directory.

4.4.3 Insert Pads

For a complete design, pads should be inserted to input and output pins in the end. Pads
should be inserted on top design only. The steps to insert pads are

Load top design as the method of section 4.4.2.1.

Link design by type command link in the field of design_vision-t>.

type set_pad_type in the field of design_vision-t>.

type set_port_is_pad [all_inputs] in the field of design_vision-t>.

type set_port_is_pad [all_outputs] in the field of design_vision-t>.

type insert_pads in the field of design_vision-t>. After a few moment, the following
message appears in the log window.

cuprwdE

Inserting I0 Pads in  Design “adderzz”’

Transferring design “adder3iz’ to database “adder32_mapped.db’
Current design is ‘adder3iz’.
1

Constrain the design as section 4.4.2.2.

Compile design as the method of section 4.4.2.3 with the option of top and scan.

Next, timing report may be generated for checking.

0. Save the design as adder32_pad_mapped_top.v and adder32_pad_mapped_top.db using
the steps listed in section 4.4.2.4.

11. With the command write_sdf to save SDF file, for functionality verification. Below is

the sample.

B oo~

design vision-t> write sdf mapped/adder32 pad. sdf
Information: Annotated ‘cell’ delays are assumed to include load delay. (UID-282)
Information: Updating design information... (UID-85)

Information: Writing tining information to file  /home/staff/elezhq/BSIC/synthesis/mapped/adder3l pad. sdf’. (WD-3)
1

Above is the normal procedure to insert pads on top design. If there are warnings or massage
like “insert pads terminated abnormally’, use commands get_attribute to check IOLIB attribute
and remove attribute like don’t_use by issuing command remove_attribute. The use of
command get_attribute and remove_attribute can be found from the pull down menu
Help->Man Pages on the design vision window.
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4.5 Conclusion

The method of synthesizing and optimizing a design is described in this chapter. It is well
known that a successful synthesis and optimization need skills on both RTL coding and design
compiler usage. User may refer to Verilog/VHDL books and synopsys DC user guide for coding
styles, besides this manual. In addition to, user can refer to DC user guide and man page for more
on DC commands and variables and their usage.

Synthesis and optimization are an iterative process. User may need to modify their source
code if violations are not able to be corrected. Generally, it can proceed to the next step if setup
time is met, no design rule violation and minor hold time violation. Fixing minor hold time
violations can be done after layout with real delays back annotated. Of course, if gross hold time
violations are detected after initial synthesis, they should be fixed at the pre-layout level.

After synthesis and optimization, user can proceed to NCLaunch for pre-layout verification.
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5. Pre-Layout Verification With NCLaunch

Pre-layout verification with NCLaunch is described in this chapter. Recalling chapter 3,
NCLaunch is just an interface where compiler is invoked to compile the source code, elaborator is
invoked to elaborate the design, and finally simulator is invoked to simulate the design. Pre-
layout verification with NCLaunch is almost as same as RTL verification. The only difference is
that a SDF file including delay information is involved. The SDF file has to be compiled first and
then $sdf_annotate system task has to be inserted into design source files. Compiling SDF and
using $sdf_annotate system task will be described in the following sections.

The arrangement is as follows. The overview of SDF annotation is given in section 5.1. The
$sdf_annotation system task is described in section 5.2. The requirements for $sdf_annotation
system tasks are presented in section 5.3. In section 5.4, a tutorial of pre-layout verification using
NCLaunch is demonstrated. Conclusion is given in section 5.5.

5.1 Overview of SDF Annotation

Refer back to chapter 3, the verification process consists of three steps, compiling,
elaborating, and simulating. SDF back annotation is performed during elaborating. The elaborator
recognizes $sdf_ammotate system tasks in design source files, and if the $sdf_annotate system
tasks are scheduled to run at time O and if they meet other requirements, annotation is performed
automatically.

See “$sdf annotate system task” in section 5.2 for a description of the $sdf _annotate system
task. See “requirements for $sdf_annotate system task” in section 5.3 for a description of the
rules that apply to the $sdf _annotate tasks for automatic SDF annotation.

5.2 $sdf _annotate System Task

The syntax of the $sdf_annotate system task is as follows:
$sdf_annotate (“sdf_file”, [module_instance], “config_file”, “log_file
“scale_factor”, “scale_type”).
The “sdf_file” argument is required. All the other arguments are optional. If optional arguments
are omitted, the commas that would have surrounded them must remain, unless the omitted
arguments are consecutive and include the last argument. Below shows two examples. First one
is that the third (“config_file”) and fourth (“log_file””) arguments are omitted. Second one is that
the last three arguments (“mtm_spec”, “scale_factor”, “scale_type”) are omitted.
$sdf_annotate (“mysdf.sdf”, m1, , , “MAXIMUM?”, “1:2:3”, “FROM_MTM").
$sdf_annotate (“mysdf.sdf”, m1, “mysdf.config”, “mysdf.log”).

, “‘mtm_spec”,

The definition of each item of $sdf_annotate system task will be listed below.
B “sdf file”
The name of the SDF file can be:
e The name of the SDF source file (for example, adder32.sdf)
e The name of the compiled SDF file (for example, adder32.sdf.X)
e The name of a compressed or zipped SDF file ( for example, adder32.sdf.gz)
e The name of a compressed or zipped and compiled file (for example,
adder32.sdf.gz.X)
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The elaborator determines the format of the SDF file, and then invokes cadence ncsdfc
utility to compile the SDF file accordingly. For small design, the format of adder32.sdf.X
is often used.

= module_instance
The SDF annotator uses the hierarchy level of the specified module instance to run the
annotation. If module_instance is not specified, the annotator uses the module that
contains the call to the $sdf_annotate system task as the module_instance for annotation.

®  “config_file”
It is the name of configuration file. The configuration file lets user control how the timing
data in the SDF file is annotated. Using a configuration file is optional. The annotator
uses default settings if it is not specified. Users may refer to NC-Verilog Simulator Help
for the description of the configuration file if interested.

= “log file”
It is the name of the annotation log file. This file contains status information, warnings,
and error messages from the SDF annotator. The annotator also prints warnings and error
messages to standard output. By default, the annotator does not create an SDF log file.
User must include this argument if the annotation specific messages are needed.

= “mtm_spec”
Specifies the delay values that user wants to annotate. The mtm_spec is one of following
keywords:
¢ MINIMUM - annotates the minimum delay value.
e TYPICAL - annotates the typical delay value.
o MAXIMUM - annotates the maximum delay value.
e TOOL_CONTROL - annotates the delay value that is specified by the command-line

option — mindelays, -typdelays, or —maxdelays.

The default for mtm_spec is TOOL_CONTROL. If no command-line option is specified,
the default is TYPICAL. The mtm_spec argument overrides the mtm command in the
configuration file.

B “scale_factor”
Set three positive real number multipliers that the SDF annotator uses to scale the
minimum, typical, and maximum timing values in the SDF file before annotating the
values. The syntax of the argument is min_mult : typ_mult : max_mult. For example,
“1.6:1.4:1.2”. The default for scale_factor is 1.0:1.0:1.0, and it overrides the scale
command in the configuration file.

= “scale_type”
Specifies how the SDF annotator scales the timing specification. The scale_type is one of
the following keywords:
e FROM_MINMUM - scales from the minimum timing specification.
e FROM_TYPICAL - scales from the typical timing specification.
e FROM_MAXIMUM - scales from the maximum timing specification.
e FROM _MTM - scales from the minimum, typical, and maximum timing

specifications.

The default for scale_type is FROM_MTM. The scale_type argument overrides the scale
command in the configuration file.

In the following example, timing information in a file called my.sdf.X is used to annotate
the module instance top.m1.
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module top;

circuit m1(i1, i2, i3, 01, 02, 03);
initital
begain

$sdf annotate (“my.sdf.X”, m1, ,,
“MAXIMUM”,

“1.6:1.4:1.2”, “FROM_MTM™);
end

endmodule

5.3 Requirements for $sdf annotate System Tasks

The elaborator ignores and generates a warning for any $sdf_annotate system task that does
not satisfy the following rules:

o $sdf annotate tasks must be inside an initial block. A $sdf annotate task cannot be
referenced in a task call contained in an initial block.
Only $sdf_annotate tasks scheduled to run at time 0 are used for annotation.
Delay or even control statements cannot precede $sdf _annotate calls
$sdf_annotate calls cannot be within or follow for, while, case, repeat, or wait constructs.
Because annotation takes place at elaboration time, and the values of variables in the
design are determined at simulation time, a $sdf_annotate task cannot be invoked from an
if construct with a variable expression as the condition. The expression that is used in the
guard expression must evaluate to a constant.

If a $sdf_annotate task violates the above requirements, the elaborator generates warning
messages telling user that it is ignoring the system task.

It is possible to override the default automatic SDF annotation mechanism and force
annotation by writing an SDF command file and then including the command file when
elaborating by using the —sdf_cmd_file option. For users who are interested in using the SDF
command file, please refer to NC-Verilog simulator help for the use and description of SDF
command file. Only automatic SDF annotation is described in this manual.

5.4 Tutorial of Pre-Layout Verification Using NCLaunch

The tutorial is divided into three parts: preparations, compiling SDF file and all the source
files, elaborating the design. User can follow the tutorial to understand thoroughly the SDF back
annotation topic. The example used is the design - adder32, and the design files are got from
synopsys DC.

5.4.1 Preparations

1. Create a working directory: mapped_ncvlog
% mkdir mapped_ncvlog

2. Copy the design file: adder32_pad_mapped_top.v, test_adder.v (referring to chapter 3 for
this file), and SDF file: adder32_pad.sdf to the directory: mapped_ncvlog.
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% cd mapped_ncvlog
% cp /the path to design files/ adder32_pad_mapped_top.v .
% cp /the path to test_adder.v/test_adder.v .
% cp /the path to SDF files/ adder32_pad.sdf .

3. Create a lib directory which holds the library files used by design.
% mkdir lib

4. Copy the library files to the directory lib.
% cp /path to library files/c35_CORELIB.v lib
% cp /path to library files/c35_IOLIB_4M.v lib
% cp /path to library files/udp.v lib

5. Modify the source file - adder32_pad_mapped_top.v to include the $sdf_annotate system
task as follows.

module adder3z ¢ a, b, cin, CLOCK, sum, cout J;

input [31:0] a;

input [31:2] b;

output [31:0] sum;

input cin, CLOCK;

output cout;

wWire A1t , n1d2, n183, n1od, n1os, n1o06, n107, N10E, N109, n11d, nil11,
ni1z2, n113, nitd, n115, n116, nN117, N118, N119, N120, N121, n12z,
n123i, nléd, n125, nize, n127, n128, nN129, nN13c, nN131, n13iz, nN13s,
134, 135, N136, N137, N138, N138, N140, N141, N142, N143, nN144,
145, nN146, N147, n143, n149, N150, N151, N152, N153, N154, n155,
n156, N157, n158, nN158, N16d, n16l, N162, N163, n164, N165, N13a,
166, N167, N1BE, NIGI, NI70, NI171, N172, N173, N174, NI75, NI7E6,
177, N178, N179, R180, N181, N182, N183, N184, N185, N186, n187,
N188, N182, N18G, N1&l1, N192, n193, N194, N195, N196, nN137, N13d, nl,
35,

wire [32:0] temp;

"FROM_MTM" 3 ;

assign n35 = CLOCK;
DFS3 cout_reg { .CCn1egd,  Dotempl32]12. .SDCM198), .SE(M1). .QCn198) )

Figure 5-1 $sdf_annotate system task in the pre-layout design source file.
5.4.2 Compiling SDF File and Source Files
Refer to chapter 3, if you forgot the usage of NCLaunch.

1. Start NCLaunch in the working directory — mapped_ncvlog as follows. You should see
the files as figure 5-2 in the NCLaunch window.
% nclaunch —-new&

Direc:tcnry:§JmeflstafffeIethfASICw}mapped_ncvlog >

-3 lib

[5] c£35_CORELIEV
[l c35_I0OLIE 4.y

I s T

adderdz_pad_mapped_topw

] test addery

Figure 5-2 Start up of pre-layout verification.
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2. Open the SDF compiler to compile SDF file by clicking on Tools=>SDF Compiler....
The SDF Compiler form appears. Set the form as figure 5-3, and then click on
Advanced Options button.

—-i Compile SDF | |

SDF File {adderaz_pad sdf

Ovenyrite log file  — | j"ﬁvcéa_fglvudg

Compile —_ |

W Output file name éédderaz_pad.sdf.x

_1 Qther Options

Advanced Options.. |

d 019 Cancel Apply Help |

Figure 5-3 SDF compiler form.

3. Set the Advanced Options form as figure 5-4. Click on Ok on both forms. The SDF
compiling starts and the ncsdf.log file creates in the working directory.

—|  SDF Compiler Advanced Options |

;Errors AhiEerates | B Print informative messages
W Display runtime status

_1 Suppress all warnings

B Suppress output to the scraen

Ok Cancel Bpply Help

Figure 5-4 Advanced Options form.

4. Check two files created during the SDF compiling: adder32_pad.sdf.X and ncsdf.log.
5. To compile all the source files, select all the source files as figure 5-5, and then click on

|
Verilog Compiler button vies | After a few moments, the compilation completes.
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BT INCA libs

SR Y

[® o5 coreLBy

[ c35_IOLIB_4hdv* |
S v

B[ picture
adder32_pad_mapped_top.v
-] test_adderv

Figure 5-5 Selection of all the source files.

5.4.3 Elaborating Design

1. Click on the top module - test_adder as figure 5-6 for elaboration.

Figure 5-6 Select top module under worklib directory.

HORE0

AORST

HOR40

HORA

adder3z

adderdz _DWO1_add_33 0
El-ggr test_adder

----- L module |

1

teeese
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0 ]
2. Click on the Elaborator button MJJ. . The Elaborator form appears. Set the elaborator

form as figure 5-7.
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— Elaborate

Cesign Unit fworklih. test adder :module

{ [lik]zel:view] )

_1 Snapshot Mame [

W Work Likirary Iwnrklih pod |
Cveryrite log file. — | Encelab.lug I
B Error Limit [ 15 ;1

_I Update if needed

B Access Visibility Al — |

_I Executable Filename | I

{ Default: ncelahb J

M Other Options ;—sdf_verbose

Aadvanced Options.. |

4 8,4 Cancel Bpply Help |

Figure 5-7 Elaborator form settings.

3. Click on the Advanced Options button on the elaborator form. Select Errors and
Messages on the Advanced Options form and set the form as figure 5-8, to get more SDF
annotation information.
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= Elaborator Advanced Options |
EVHDL reihne B Print informative messages
Werilog Perfarmance
Emars and Messages | W Display runtime status
Timing
|Programming Language Interface _I Suppress all wamings
annatation
\General _| Suppress specific warnings |
_1 Disable printing of timing check warnings
_| Suppress output ta the screen
_I Suppress 50DF errors
_| suppress SOF warnings
_I Suppress SDOF header

Frint timing checks convergence warnings

—WHDL Only

_i Disable printing of glitch messages

—Werilog Cnly
_| Dizahle ¥PIPLI warning and error messages
_! Disable ¥PIFLI messages caused by optimizations

_| Printmessages about resolving instances

Ok I Cancell Bpply I Help |
n I

Figure 5-8 Advanced Options form settings.

——

Click on Ok on both forms. The elaboration starts and it completes after a moment.
Check the messages in the NCLaunch window. If the SDF annotation is successful, the
following messages should appear.

annotating S0F timing data:
Caompiled SDF file adderds pad.sdfx
Loy Tile: sdf.log
Backannotation scope: test adderblock]
Catfiguration file:

MTH control: P& R IMLURA
Scale factors:
Scalefype: FROM_MWTR

_A_nnot_a}tlgrl..:_umpleted successiully..
Figure 5-9 Elaborating messages.

A sdf.log file should be created in the working directory. Open it to view the annotation
timing data. The sdf.log file of example adder32 is shown in figure 5-10.

64
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— Terminal |15

Window Edit Options Help

Arnotating SOF timing data:
Compiled SDF file: adderiz_pad.sdf ., x
Log file: sdf . Tog
Backannotation scope: test_adder. blocki
Configuration file:

MTM contral: M&R ITMUM
Scale factors:
Scale Tvpe: FROM_MTM

Time units: 1ns
annotating to instance NMo3 of module ITUP
ABSOLUTE CIOPATH PAD Y3 = (0.215, 0.262)

arnotating to dnstance Moz of module ITUP
ABSOLUTE CIOPATH PAD Y3 = (0,215, O,262)

Anrotating to dnstance o1 of module ITUR
ABSOLUTE CIOPATH PAD %) = (0,215, 0.262)

Annotating to instance U100 of module ITUP
ABSOLUTE CIOPATH PAD ¥) = (0,215, 0.262)

annotating to dnstance U89 of module ITUP
ABSOLUTE CIOPATH PAD ¥ = (0,215, 0,262)

arnotating to dnstance USE of module ITUPR
ABSOLUTE CIOPATH PAD Y3 = (0.215, 0.262)

annotating to dnstance US7 of module ITUFR
ABSOLUTE CIOPATH PAD ¥ = (0,215, 0.262)

annotating to dnstance U926 of module ITUPR
ABSOLUTE CIOPATH PAD Y3 = (0,215, 0.262)

< "sdf.log” 16843 lines, 76028 characters

Figure 5-10 sdf. log file.

Now the elaboration finished. A snopshot — worklib:test adder:module is created after the
elaborating. Select the snapshots as figure 5-11, and start simulation to get the pre-layout
simulation results.
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—| NCLaunch : /nome/staff/elezhq/ASIC/mapped_ncviog | - ||

File- Edit Tools Utilities  Plug-In

5 Help

Browsers: Tools: S ..:.EL| : ﬁ @ P
Directury:i.n’homefstafffelethmSICfn:| [1...@ HMRA0 iy
e - g HMRAT
@ INCA_libs Hoge HOR2O
: Hoghe HOR21
J5] ©35_CORELIBY" o KOR22
£35_IOLIB_ah.v* e XORID
LY udpyr Hop HORST
® (O picture Hogr HOR40
adderdZ_pad_mapped_top.y U"'@ #OR4
test_adder.y Bloghe adderaz
Bl adderdz_ DW01_add_33_0
Elga test_adder
I module
B3 Snapshots
X Il , P
Filters:!".u *vhd * vhdl Zl_ @ worklib test_adder:module | -;
Bullding Instance averay tables: ... Dane X
Loading riative compiled code: L Dane
Bullding Instance specific data structures
Design hisrarchy summary
Instarces Unigue ]

| 1 items selected

Figure 5-11 Select the snapshots to prepare for simulation.
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Because simulating a pre-layout design is as same as simulating a RTL design after

elaborating, the simulation methods are not repeated in this chapter. User can refer to chapter 3:

= section 3.2.3 for starting the simulator,
= section 3.2.4 for simulating the design, and
= section 3.2.5 for displaying simulation data.

5.5 Conclusion

Pre-layout verification including SDF back annotation is described in this chapter. Comparing
to Chapter 3, the only difference is that the SDF file needs to be compiled first and $sdf annotate
system task has to be stated in the design source file. What users need to do is following the steps
listed in section 5.4 and section 3.2.3, 3.2.4 and 3.2.5 of chapter 3, to finish the pre-layout

verification.

Now, it is time to bring the design to next chapter for pre-layout static timing analysis if the

verification is satisfactory.
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6. Pre-Layout Timing Analysis Using Synopsys PrimeTime

After getting the gate level netlist from DC, it should be brought to primetime (PT) for Static
Timing Analysis (STA). The purpose of STA is to investigate the design on the aspects of setup
time and hold time, and to find out the paths which violate the timing targets and the sub-blocks
which have no more improving space (bottleneck blocks). By analysis the information, designer
is able to decide how to improve the performance of the design.

The arrangement of the chapter is as follows. An introduction to STA is presented in section
6.1. The method of reading design data is described in section 6.2. Constraining design is
mentioned in section 6.3. Specifying timing exceptions are given in section 6.4. In section 6.5,
checking and analyzing design is described. The types of STA are presented in section 6.6. A
tutorial of using PT with the example - adder32 is demonstrated in section 6.7. Lastly, conclusion
is given in section 6.8.

6.1 Introduction to Static Timing Analysis

STA verifies that every flip-flop in the design meets its setup and hold time requirements,
where the definitions of the setup and hold time are shown in figures 6-1 and 6-2 respectively.
STA uses SPICE characterized data stored in a technology library to verify gate level circuit
timing.

EQN 1 15Iackmup = Data Required Time — Data Arrival Time > 0 |

EQN 2 I S|aCKs&tup = {Tcapture - tsetup )_ {Tlaur}?h * tpn:}y} 20 l

FF1/CLK _‘—l—[—]—

FF3/CLK

FF3/D

1

! Data Arrival Time | |

: | 4= Data Required Time
]

1
—ai  le— Slack

Figure 6-1 Setup definition.

EQN 1 | Slack,,,, = Data Arrival Time — Data Required Time > 0 ‘

EQN 2| Slackygig = ( Tiaunen * torop ) =  Teapture * thog) = O

FF1/CLK m

FF3/CLK

Pl K

Seteteletetete:N
BRRO
o O

1
Data Arrival Time 1—IL>|
Data Required Time -Q-HI :
L, ;4— Slack

FIT IO 58N
LS,

IR IR XX X X i
L e A N . +_¢._¢.

FF3/D

Figure 6-2 Hold definition.
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There are two main steps in STA:
= The delay of each path is calculated (data arrival time),
= All path delays are checked to see if setup time and hold time (timing constraints)
have been met (Slack >=0).

Each timing path has a start-point and end-point. The start-point is input ports and clock pins of
flip-flops or registers, and end-point is output ports and data input pins of sequential devices. The
actual path delay (data arrival time) is the sum of net and cell delays along the timing path, where
the net and cell delays are provided by the technology library.

Timing and design rule are checked during STA. PT checks for setup and hold requirements
of every timing path in the entire design based on specified constraints, and it checks for
following design rule constraints:

= Capacitance: max_capacitance and min_capacitance
» Transition: max_transistion and min_transistion
= Fanout: max_fanout and min_fanout

STA flow is shown in figure 6-3. As the figure shows, there are five steps in STA. Each of the
five steps will be described in the following sections.

CONSTRAIN
EXCEPTION

ANALYZE

Figure 6-3 STA flow.

6.2 Reading Design Data

There are three steps to read design data.
e Setvariables: search_path and link_path.
o Read design.
e Link design.

As running DC, a setup file .synopsys_pt_setup needs to be created, which defines the two
variables: search_path and link_path. The definitions of the variables are given below:
e search_path defines the path which PT will search for when necessary, and
o link_path specifies where PT searches for designs and technology (library) files
when linking the design.

A setup file defining the two variables are shown in Table 6-1, where * stands for PT
memory. User can use the commands: printvar search_path and printvar link_path to verify the
settings after invoking PT.
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Table 6-1 .synopsys_pt_setup file.

set search_path ~ “$search_path scripts mapped reports”
set link_path “* [path to tech installation directory/tech_lib.db”

To read, PT uses the commands:
e read_verilog — to read netlist in Verilog;
e read_db - to read netlist in db format;
e read vhd -to read netlist in VHDL format.
Table 6-2 shows the method to read and link a design which has sub-designs in three different
formats.

Table 6-2 Read and link design®®.

pt_shell> read_verilog “sub_designl.v,..., top.v” Verilog format
pt_shell> link_design top
pt_shell> read_db “sub_designl.db, ..., top.db” db format

pt_shell> link_design top
pt_shell> read_vhd “sun_designl.vhd, ..., top.vhd” | vhdl format
pt_shell> link_design top

If there is error message when reading/linking design, user needs to check the search_path
and link_path variables defined in the setup file. By default®, PT will create black boxes if
link_design couldn’t solve a particular reference.

6.3 Constraining Design

PT accepts the constraint file which is used by DC. User can use the constraint file of DC, if
there is no specific requirement. For user who is interested in knowing more about constraints,
please refer to DC and PT documents.

6.4 Specifying Timing Exceptions

Timing exceptions are used to override the default single-cycle constraints described by
create_clock, set_input_delay, and set_output_delay. Timing exception commands are listed in
table 6-3. The usage of set false_path and set_multicycle_path is described below, and user can
refer to PT document for the usage of the rest .

Table 6-3 Timing exception commands.

set_false_path: Removes timing constraints from timing path
set_multicycle_path: Allows more than one clock cycle for a timing path
set_max_delay: Specifies max and min delays on paths

set_ min_delay:

report_exceptions: Reports current timing exceptions

reset path: Restores the default timing constraints on specified paths
transform_exceptions | Performs transformations on timing exceptions

28 Mixed netlist also works, referring to PT document.
|t is because that the variable link_create_black_box is true by default, referring to PT manpage for the
variable.



Author — Zheng Huan Qun 70

» Set _false_path

The usage is shown below, referring to figure 6-4.
pt_shell> set_false_path —from A —to R1/D (referring to figure 6-4 (a))
pt_shell> set_false_path —through R1/Q (referring to figure 6-4 (b))

aD-«-._’_“_._. - o}—" “*—po q]--- EERE I Sl z s I
Rl R2

R1 R2

> >
elkl > > i—> clk > [ [

(@) (b)

Figure 6-4 Circuit diagram.

> Set_multicycle_path®
The usage is shown below, referring to figure 6-5.
pt_shell> set_multicycle_path 2 —-from FFA/CP —through Multiply/Out —to FFB/D

f'l'_w_t_)-Cycl? Path -through
-from : o
In Multiply '
cut
\ - §s
CP iz

sel

Add

Ohé_-Cyc le Path

Figure 6-5 Diagram of multi-cycle path.

PT performs a default hold check at O if it is not specified explicitly. For examples,

create_clock —period 10 [get_ports CLK]
set_multicycle_path —setup 6 —to [get_pins C_reg[*]/D]
set_multicycle_path —hold 0 —to [[get_pins C_reg[*]/D] < IMPLICIT

It can be override with the command ‘set_multicycle_path —hold 5 —to [[get_pins C_reg[*]/D]’.
The command means the hold check is at 5" cycle.

6.5 Checking and Analyzing

The objectives of checking and analyzing are to
= find out the scopes of violations,
= do a complete analysis to identify timing and DRC violations,
= jdentify bottleneck blocks in the design as candidates for re-synthesis, and
®  provide “Info Reports” for the largest violations on input paths, reg-to-reg paths and
output paths.

% please refer to the PT manpage for details.
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6.5.1 Checking

Check design before analyzing is necessary. Check design is to assure that it is fully
constrained and to identify problems with design constraints like:
= missing clock definitions,
= ports with missing input delay,
= unconstrained endpoints for setup,
» input/output delay set without a reference clock,
= combinational feedback loops, and more.
The command to check design is check_timing -verbose.

6.5.2 Analyzing

There are three analysis techniques. They are
=  Constraint Report: report_constraint® —all,
= Bottleneck Report: report_bottleneck, and
= Timing Report: report_timing.

» Constraint Report

Constraint report (report_constraint) shows all types of violations in a design: setup, hold,
DRC, and pulse width.... The default is to show the longest violation of each type. With option,
the command can specify the violation what user wants to investigate. Below are the maost often
used options:

= -all_violators - showing all the violations in a design and where the violations are;
= -all -max_delay —min_delay - showing all the setup and hold violation;
= -all -max_capacitance -max_fanout shows all the DRC violations.

» Bottleneck Report

Bottleneck analysis identifies the cells (or blocks) which are involved in multiple violations.
With bottleneck analysis, users are able to identify sub block(s) containing bottleneck cells, to re-
synthesize the sub block(s), and then to replace the sub block(s) with newly synthesized sub
block(s).

Bottleneck report command is
= report_bottleneck —cost_type path_count
where path_count is the default cost_type and it uses the number of violating paths through the
cell as the bottleneck cost. Figure 6-6 shows an example of bottleneck analysis.

* It is as same as DC command but more powerful.
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Figure 6-6 Bottleneck figure.
> Timing Report®

Timing report (report_timing) command finds all the individual timing paths in the design for
analysis. Each path is analyzed for timing twice, once for a rising edge input and once for a
falling edge input. PT organizes its timing reports by path groups. By default, the critical path
(worst violator) for each clock group is found and reported.

For easy analysis, user can group timing paths with the command group_path —name.
Examples to group timing paths are shown below. The commands are shown in table 6-4 and the
circuit and grouping diagram are shown in figure 6-7. User can also group paths by clocks if
design has more clocks.

MY DESIGN
' ouT
CLK > @
CLK
Timing Paths Path Groups

Figure 6-7 Timing paths and path groups.

Table 6-4 Commands to create groups.

group_path —name IN —from [all_inputs]
group_path —name OUT —to [all_outputs]
group_path —-name COMBO —from [all_inputs] —to [all_outputs]

User can specify a path to report with the options: -from and —to. The timing report for setup
and hold checks are created with the commands shown in table 6-5. Keep in mind that
report_timing by default reports one path with the worst slack within each path group.

% It is as same as DC command but more powerful.
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Table 6-5 Timing report for setup and hold checks.

report_timing —delay max Setup check report

report_timing —delay min Hold check report

report_timing —delay min_max Setup and hold check report
report_timing —max_paths 10 Multiple timing reports. It contains the
report_timing —nworst 10 analysis of at most 10 slowest paths.

6.6 Types of Static Timing Analysis

There are four types of analysis: single operating condition (OC) analysis, best case
(BC)/worst case (WC) analysis, on-chip variation, and case analysis.
» Single OC Analysis

The command is shown below, where WORST (or BEST) is one of the conditions of library

and lib_name is the library name used for design. Using WORST is for Max paths timing and
using BEST is for Min paths timing.

pt-shell>set_operating_conditions —analysis_type single WORST (or BEST) —library
lib_name

» Best/Worst Case Analysis

It is used to specify both a min and a max OC. The command is shown below.

pt-shell>set_operating_conditions —analysis_type bc_wc -library lib_name -min
BEST —max WORST

As for on-chip variation and case analysis, user may refer to PT user guide.

By default, PT performs analysis based upon a single OC. If no operating conditions are
specified for a design, the tool uses the default operating condition of the library which the cell is
linked to. If the library does not have default operating conditions, no operating conditions are
used. User can specify analysis type in the design constraint file.

6.7 Tutorial of Using PimeTime

The following steps show the flow of STA using PT. The example used is the adder32 and its
netlist is got from DC.

6.7.1 Preparations

1. Use the project directory of DC.
2. Creating the setup file as below, and save it as .synopsys_pt setup file in the project
directory.
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set_search_path "/path to the installation directory of foundry/synopsys/c35_3.3V\
/path to the project directory/mapped/db”
set link_path "* ¢35_CORELIB.db c35_IOLIB_4M.db"

3. Create a constraint file as below, and save it as adder32_pt_constr.scr in the scripts
directory.

current_design adder32
reset_design
create_clock -per 100 -name clk [get_ports CLOCK]

set_dont_touch_network [get_ports CLOCK]
set_clock_uncertainty -setup 0.3 [get_ports CLOCK]
set_clock_uncertainty -hold 0.3 [get_ports CLOCK]

%set_operating_conditions -analysis_type single WORST -library c35_CORELIB
set_wire_load_model -library ¢c35_CORELIB -name 10k
set_wire_load_mode enclosed

set_input_delay -max 2 -clock clk [all_inputs]

set_input_delay -min 0.4 -clock clk [all_inputs]
remove_input_delay [get_ports CLOCK]

set_driving_cell -library c35_CORELIB -lib_cell BUF8 [all_inputs]
remove_driving_cell [get_ports CLOCK]

set_output_delay -max 0 -clock clk [all_outputs]
set_output_delay -min 0 -clock clk [all_outputs]

set_load 0.1 [all_outputs]

6.7.2 Invoking PrimeTime GUI and Verify Setup

1. Start primetime with the command primetime. Figure 6-8 shows PT GUI. Notice that
there are three main part on the interface - Logical Hierarchy, log and pt-shell> prompt.
%primetime&

* Note the difference from adder32_dc_constrc.scr.
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Figure 6-8 PT GUI.

2. Locate the command line (pt_shell prompt) to verify the environment with the following
command.

pt_shell>printvar link_path
pt_shell>printvar search_path

pt_shell> printvar link_path

link_path =" £35_CORELIB.db c35_IOLIB_4M.db"
pt_shell> prirtvar search_path
search_path = "fapp21/AME_3 60 CO5_Frsynopsysicds_3.3Y Jappz2isynopsysssynthesis_200406p7fpackagesAEEEM Mamelstafifelezhof ASICynthesis/mappedidy

Figure 6-9 Messages of the log area.
6.7.3 Reading, Constraining and Checking Design

1. Read the design netlist with the command: read_db. Figure 6-10 shows the message in
the log area.

pt_shell>read_db adder32_mapped.db

pt_shell> read_db adder32_mapped.db

Loading dh file Yhomesstafifelezhg/851C synthesis/mapped/dh/adderid_mapped.di’
1

Loading dh file Yapp21/ah5_3.60_CDS_F/synopsys/cdn_3.3%/c3a_CORELIB.AR

Loading dh file Yapp21/ahS_3.60_CD5_F/synopsys/cds_3.3vV/c3o_OLIB_4M.dh’

Linking design adder3z...

Information: [ssuing set_operating_conditions equivalent to timing_propagate_single_condition_min_slew setting, (FTE-037)
set_operating_conditions -analysis_type on_chip_variation -library {get_libs {c35_CORELIB.dh;c35_CORELIB])

Figure 6-10 Messages of read_db .
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2. Link the design with the command: link. The Message “Design ‘adder32’ was
successfully linked” appears in the log window after the design is linked.
pt_shell>link

3. Constrain the design with the constraint file. On the primetime window, click on
File->Execute Script.... The Execute Script File window appears as shown in figure 6-
11.

— Execute Script File T

Look in: I._-ja’hnmefstaﬁfeIethmSICfsynthesisf

&

[_1libs
_Imapped

[ Jreports
_sctipts
_Junmapped
] werilog

[ Jwork

File name; ’adderSZ_pt_cunstr.scr
< File type: I Script Files ( “.script “.scr ".dcs ".docy “dc “.con "tcl ll Caneel | b
i

Figure 6-11 Execute Script File window.

4. On the above window, click on the folder - scripts and choose the file:
adder32_pt_constr.scr and then click on Open.

5. Check clock applied. The report appears in the log window as shown in figure 6-12.
pt_shell>report_clock

pt_shell= repont_clock

Repart : clack

Design : adder3z

Yersion: W-2004.12-5F2

Date : Thu Moy 10 16:10:52 2005

EEE R PR PR PR PR R PP R PP

Attributes:
p - Propagated clock
G - Generated clock
| - Inactive clock

Clock Feriod ‘Waveform Attrs Sources

clk 100,00 {0 507 {CLOCK]

Figure 6-12 Messages of report_clock.
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Check the constraints applied. Manage to solve any warning and error if there was.
pt_shell>check_timing —verbose

pt_shell= check_timing -verhose

Infarmation: Using automatic max wire [oad selection group “sub_micron® (ENY-003)

Warning: Some timing arcs have been disabled for breaking timing loops
or because of constant propagation. Use the “repot_disakle_timing”
command to get the list of these disabled timing arcs. (PTE-003)

Information: Checking no_clock’.

Information: Checking no_input_delay’,

Infarmation: Checking “partial_input_delay’,

Infarmation: Checking *no_driving_cell”.

Information: Checking ‘unconstrained_endpoints”.

Information: Checking “unexpandable_clocks’.

Information: Checking “generic’,

Information: Checking atch_fanout’.

Information: Checking “loops’.

Infarmation: Checking ‘generated_clocks’,

check_timing succeeded.

1

Figure 6-13 Messages of check _timing in log area.
Analyzing Design

Analyze the design timing using the Endpoint Slack Histogram.
On GUI, click on Timing—=>Histogram->Endpoint Slack.... The Endpoint Slack
window appears as shown in figure 6-14.

—| Endpoint Slack |

Delay type: [m

—Binning settings
@ Mumber of hins: | =

-

" Malue range per bin: I
I <= Glack == I

B Lowerpqund strict I Upper hounq strict

—Histogram settings

M asimum: (autoscale)

Histogram title: |Endpnint slack

M-ais title: [Slack

Y= axis title: |Number of Paths

3 (8] € I Cancel | Apply

k\ L

Figure 6-14 Endpoint Slack window.

Keep the default settings and Click on Ok on the endpoint slack form. The endpoint slack
window appears as shown in figure 6-15.
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Figure 6-15 The endpoint slack.

Click on the left most one on the endpoint slack window. The 6 endpoints with their
respective slacks appear on the right of the window, shown in figure 6-16.

«HistList1  Endpnoint Slack

Endpoint Slack | WIFI

73125 sum_reg[31)/D

34
33 — 75.3571 cout_reg/D
30 79.7649 sum_reg[30)/D
ot 7E4048 sum_reg[23)/D

77.0446 sum_reqg[28)/D

Z0 77.6645 sum_reg[27)/D
15
10
5 . =]
0t - "u'u"' =

7506634 973
‘ I' L0 =%, uys '..L.I:.HJ

Figure 6-16 Illustration of slack histogram.

To investigate a path, highlight it, and then right click on your mouse and choose
Inspector for Worst Path to Selected Pin. For example, highlight the top most entry on
the right hand. The PrimeTime TopLevelPathInspector window appears, shown in
figure 6-17.
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Clock Name: clk {rising edge)

Latency: 2

Endpoint:
Name:; sum_reqg[31],/D
Clock Name: clk (rising edge)

Latency: 0.4 Library setup: 0. 265836

Uncertainty: 0.3 Data required: 09,8342

Skemw: -1.6 Data arrival: 24.7091 =
5lack: 75.125 |

|Pin: sum_reg[31)D|  E»

Figure 6-17 Path inspector window.

5. Click on the Waveform button on the path inspector window, the waveform of the

specified path appears, shown in figure 6-18.
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—-| PrimeTime — ToplLevelPathinspector.3 — [Pathlnspector.3] | : |_||

& File Miew Highlight Schematic Beporn Waveform Window . =

[aggnal]s aaollkt]= <]

From:i 1] 1] delay:! hMaxRise

Select i oo |sum_reg[a1/D slack: | 75.125

Surrmary iClDCk ]Data Path iWaueform I
Path from b[0] to sum_reg[31)D (slack = 75.125) =

latency
2.0
clkib[]) arrival

Launch path

(Pin: sum_reg[31}D| B y

Figure 6-18 The waveform of the specified path.

[

Click on the button | more information related to the waveform will be shown.

7. Click on the CLOCK and Date Path button, to view other information.

©

6.7.5 Generating Reports

1. Generate the timing report with the following command.
pt_shell>report_timing
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pt_shell= report_timing
Report : timing
- path full
-delay max
- max_paths 1
Design : adder3z
Wersion: W-2004.12-5P2
Date : Thu Moy 17 13:42:57 2005

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Startpaoint: b0] (input pott clocked by clk)
Endpoint: sum_reqg[31]
{rising edge-triggered flip-flop clocked by clk)
Fath Group: clk
Fath Type: max

Paint Incr Path
clock clk (rise edge) 0.00 0.0o
clock netwark delay {ideal) 2.00 z.00
input external delay 2.00 4.00f

e e PR

Figure 6-19 Timing report in the log area.

2. Generate a constraint report:
pt_shell>report_constraint —all_violators

3. Restrict the report to timing violation only, use the following command.
pt_shell>report_constraint —all -max_delay —min_delay

4. To analyze timing bottlenecks in primetime GUI, click on
Timing->Histogram->Timing Bottleneck.

6.7.6 Exit PrimeTime

To exit primetime, do one of the followings.
= pt_shell>exit or
= On primetime GUI, File->Exit.

6.8 Conclusion

The concept and usage of PT are described in this chapter. As mentioned, there are 4 types of
STA, user needs to decide which type to use when doing STA. Exceptions and analysis type can
be defined in a script file — constraint file, for easy to process.

It is known that DC can check timing, but PT is more powerful than DC for check timing. PT
functions can be further explored by playing around with the pull down menu and tool icons. The
online help and manpage are very helpful when there is a doubt.

Next, the design source should be brought to cadence silicon ensemble for place and route if
the timing is satisfactory. Otherwise, user may need to go back to DC to further optimize the
design, referring to the ASIC design flow stated in chapter 1.
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7. Place and Route with Cadence Silicon Ensemble

Place and route are described in this chapter. Silicon ensemble (SE) is an area based standard
cell place and route tools — no channels are used and therefore also no compaction after routing is
possible. The router will not change the placement of the cells. It tries to route in the given area.

User can include some blocks in the placement, but SE is mainly a standard cell router.

In this manual, designs with only standard cell are considered. The arrangement is as follows.
In section 7.1, the overview of SE flow is introduced. A simple introduction of SE graphic
interface and online help is given in section 7.2. The introduction to the starting scripts of AMS
kits is presented in section 7.3. The tutorial of using SE to place and route with AMS design Kits

is demonstrated in section 7.4. Finally the conclusion is given in section 7.5.

7.1 Overview of Silicon Ensemble flow

Figure 7-1 shows the production flow. The steps to do place and route are as follows.

Freh WSl Y Ry
SE Iibrav
(LBRARY)

/

open LBRARY

Import DEF ,
Verilog, SDF/GCF

save nboox

SRR P
SE design db
(nhxxx)

Design
netlist
DEF
or
Verilog

VSize
Connect Rings

Save vsxxx

* Floorplanning is typically performed
using a number of interactive commands

Floorplan * QPlace
Plan Power | Blocks and
Save flxxx Cglls

: % Save gpxxx

CTGen

Nl

report summ

reportrc
report delay
report const
report dist

Pearl TA !

Global Route/
Final Route

or
warp router/
ultra router

Save frxxx

Verify

Save ctxxx

—®

Design

Export GDSII

rPopNPE

Figure 7-1 SE flow.

Import Library files to setup the SE library.

Import the design netlist (DEF and/or Verilog files).
Create a floorplan and pre-placement power rings.

Run standard cell placement with Qplace.
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o

Optimize the floorplan with VSize - Optional®

Create a clock tree with CT-Gen commands.

7. Make the required power supply connections to all of the macro cells with the
special router.

8. Wrouter generates a plan for signal routing and completes the inter-connection of
the macro cell inputs and outputs.

9. Export parasitic RC, delays, netlist and GDSII of the routed design.

Sk

7.2 SE Graphical Interface and Online Help

7.2.2 SE Graphical Interface

Start SE with the command
seultra -m=<memsSize>,

where the memSize can be 12, 24, 36, 48, 60, 72, 84, 96, 108, 120, 150 or 200 Mbytes
(depending on hardware memory limitation). The command displays the SE graphics interface
window on top of other x-term windows. Figure 7-2 shows the functions of each area of the
window. There are six areas in the window —Message, Artwork, Command, Context, Icon and
Object Selection. To view more messages, users can enlarge the message window by dragging the
widget up.

B Message area shows the message of each command.
= Artwork Window shows the design.
= Command field allows user to enter a command.
®  Context area shows the relative position of the viewing area to the whole design.
®  |con area contains icons (commands) which are often used.
B Object Selection area is used for user to set what is viewable and what is selectable.
/r Men Banner \
Artwork Window
Ob{'ect_
Selection
lcons
Context Message ‘!;I_
Enlarge the message window by dragging this widgét up
Command

\L . ‘ . =4

Figure 7-2 SE graphical interface.

% Refer to SE user guide, for floorplan optimization.
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The user interface and command behavior are controlled by environmental variables. The Edit
Environment (Edit=>Environment) command allows user to
= view all variables and current settings,
B search for variables, and
= change variable settings.

7.2.2 Using Online Help

There are two types of online help:
B Help buttons;
= Form Help.
To use the help buttons, click on Help—> Getting Started (or Commands) on SE window. There
is also a help button at the bottom of each form. Simply clicking on Help, a window describing
the function of the form will appear.

7.3 Introduction to the Starting Scripts of AMS Kits

AMS design kits has a script ‘ams_se’ to setup the environment for using AMS kits and
cadence SE. The command to run the script is ams_se —t <technology>. The script will create the
followings.

®  Setup directory structure.

Working directory
! DB (SE database)

VERILOG (Verilog Netlists)

: LEF (Additional LEF files)

| DEF (DEF files)

: CTGEN (CTGen Run directory)

Prepare a ‘se.ini’ file for initializing SE.

Prepare macro files: gemma.mac, fillperi.mac, fillcore.mac.

Prepare gcf files — used for importing CTLFs into SE.

Prepare a DEF/power_corner.def file — template that can be used to insert power
pads and corner cells into design.

Prepare CTGen command files: ctgen.cmd, CTGEN/ctgen.const, ctgen_post.cmd.

m  Prepare a GDSII Map File: gds2.map.

The above directories and files will be used in the place and route. The “.mac’ file is
command file. It can be executed after having started SE by clicking on File->Execute.... Users
need to modify those *.mac’ files accordingly to their design. It is best for users to have a look at
the ‘gemma.mac’ file.

7.4 Tutorial of Using Silicon Ensemble with AMS Kits

The whole design flow will be demonstrated in this section. The sample used is the adder32
whose netlist is got from chapter 4 and has passed the pre-layout verification and pre-layout STA.
The design kits used is AMS CMOS 0.35um. For users who are using other foundry, please refer
to the foundry vendor for ENV setup.
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7.4.1 Setup for Using SE and AMS Kits

1. Create a directory.
% mkdir layout
% cd layout

2. Run script: ams_se —t ¢35b4 (c35b4 is technology used) in the directory. Figure 7-3
shows the output of the command.

ss1% ams_se —t c3Ehd

#ew pectory DE created

w#w nipactory CTGEN created
w#w niprectory VERILOG created
w#x# niprectory LEF created

##& Dipectory DEF created

¥EE Creating a new se.ini file. ..

new Jemma. mac file. ..

new fillperi.mac file. ..
new fillperi_c.mac file. .,
new fillcore.mac file. ..

wEE Craating
wEE Cragting
wEE Cragting
wEE Cragating

TR TR T

new C35b43, 3% . gct file
**% Creating a new . /DEF/power_corner_c.def file
*#% Craating a new . /DEF/power_corner. def file

¥EE Creating a
a
a

wa# Cragting a new | Soctgen.cmd file
a
a
i

wEE Cragting new | /ctgen_post.cmd file
wEE Cragting new ,fctaen.const file
File pearls. ov.cmd not created

*2% Creating a new pearl3. 3v.cmd file. ..

*EE Cragting a new gdsz.omap File. ..
##% Creating a c35_cell.map file

Figure 7-3 Output of script - ams_se

3. Copy the LEF files needed by the design to the LEF directory.
% cp /kit_install_directory/artist/tHK_C35/LEF/c35b4/c35b4.lef LEF/.
% cp /Kkit_install_directory/artist/HK _C35/LEF/c35b4/CORELIB.lef LEF/.
% cp /Kkit_insstall_directory/artist/HK_C35/LEF/ ¢35b4/10LIB_4M.lef LEF/.
4. Copy design netlist to VERILOG directory.

7.4.2 Loading LIBRARY

1. Start SE with the command: seultra—-m=200&. The SE window appears as shown in
figure 7-4.
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Silicon Ensemble ==
Help

Fle Edit View Floomplan Hace Roule Report Verify

Scale: Big
Object 51 ¥s

Region

N @

X 0.21 ¥ 1,00 dx 0.2l dy 0,00 Sel 0

Al1 Rights Reserved
Wersion 5.4.35 MASTER (SEDb 5, 1) 9-May-2002 21:32.54
SET VARTABLE DRAW ROW AT ON;

Figure 7-4 SE graphic interface.

2. To load the LEF files which include the descriptions of the technology used, click on
File=> Import>LEF... and the Import LEF form appears as shown in figure 7-5.
Choose c35b4.lef and then click on OKk.

—-i Import LEF I |

Filter
* lef

Directory and File List

[ Up one directory ]
GORELIE. lef
IOLIE 44 lef

¢3E5hd. lef

Selection
Jhome /staff felezhg/ASI0layout /LEF /c3Ehd. lef
Report. File
importlef. rpt Brovrse...
Options
Clear Existing Design Data Expand Paths

Case Sensitive Hames

oK Apply Cancel Variables Help

Figure 7-5 Import LEF form.
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Note: repeat this step for the standard cell library needed by the design. For this example,
CORELIB.lef and IOLIB_4M.lef must be imported.

3. To import the timing data of the technology, click on File>Import=>Timing Library...
and choose ¢35b43.3V.gcf as shown below. Then click on Ok.

—| Import Timing Library |

Filter
*igoE

Directory and File List

[ Up one directory |
CTGENS

|DES

\DEF /

LEF/

[VERILOG/

|c35h43. 3% gef
|picture/

Selection
wme/staff felezhg ASIClayout /c35b4 3. 3. gof

Report Fle -

| LERARY. InportTiming. rpt Browse...

0K Apply | Cancel |Variables| Help

Figure 7-6 Import timing data form.

4. To load the models of the digital standard cells from the foundry, click on
File=> Import->Verilog... and then click on Browse... on the ImportVerilog form.
Choose the standard cells needed by the design. The models chosen for this example are
shown in figure 7-7.

= MultiBrowse
| Filter Selected Files
s = | /homefstaff felezhg/BSTC Dayouts, . /. 4/ f  fappll /aMS 270 CDS F/verilog/c3Shd/c35 CORELIE. v
: | fhome fstaff felechg/ASI0 Layouts. . /.4 4. F . fappll/BMS 3. T0_CDS_F/verilogs/cdShd /o35 IOLIE 4M. v
Directory and File List | /honefstaff /elezhg /R8I0 layouty /. /. ./ f.  fapp2l/BMS 3. 70 CDS F/verilog/c35hd/FILLANT. v
[ Up one directory
| FILLANT. v
¢35 _CORELIE v add|

|35 CORELIE 3B v
|c35 TOLIBG 3B_4M v
|¢35_TOLIEG ANA 3B 4
| c35_TOLIEYE 4M v Del
|¢35 IOLIB 3B 4M. v
| c35_TOLIB 44 v
|¢35 TOLIE ANA 3B 4K
| ¢35_I0LIE_&Wa 4 v
¢S UDP. v

| S.electiun

1log/c35bd /FILLANT. v

Ok Cancel | Help

Figure 7-7 Load Verilog code of digital standard cells.
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5. Click on Ok on the MultiBrowse Form.
6. Type DesignLib in the Compiled Verilog Output Library field of ImportVerilog form

as shown in figure 7-8, and then click on OKk.

7.

Import Verilog |

— Verilog Source Files
fyerilog/c35hd /FILLANT. v Browse...)
— Verilog Top Module -

- Compiled Venlog Reference Librares —

— Compiled Verilog Output Library

. DesignLil
Options
Power Nets

| Ground Nets |

Logic 1 Met
Logic 0 Het

| Special Hets

oK Cancel | Variables| Help

voD!

| Grm!

rdd3o! wdd3rl!l wdd3cZ!

grnd! gnd3c! gnd3ol

21 gnd! gnd3ol gnd3rl

Figure 7-8 ImportVerilog form settings.

88

Save current design as Lib_adder32 by selecting File->Save As, and type Lib_adder32
in the Design Name field as follows.

Save As |

- Design Directory
mefst..aff/elez}ll-qthIC/layouthBi Browse...||
- Design Hame :

l Lih_adderSi

| Keep Editing Current Design

0K | cancel | Varables Help

Figure 7-9 Save As form.

Lib_adder32 is the library for the design. It is saved in DB format, and can be loaded in

future when necessary.
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7.4.3 Importing Design and Initializing Floorplan

Start SE and load the library — Lib_adder32 saved in section 7.4.2 by clicking on
File=>Open... if SE is closed in the end of last section.

1. To load design, click on File=> Import->Verilog.... Fill the first four fields of
ImportVerilog form as figure 7-10, and then click on OKk.

—i Import Verilog | |

— Yerilog Source Fles .
1dder3.2._pad_mapped_top.v?_l Browse... |
— Verilog Top Module - :
. adderSi
Compiled Vetlog Reference Libraries - :
| DesigrLil
[ : Compiled Verilog Output Library
: cds_whir
Options .
Power Mets | 7dd3o! wdd3rl! wdd3cZ! .
| Grouni Nets | ged! gndde! gnd sl
Logic 1 Met -V'DD!
Logic 0 Het | snp!

| Special Nets | 21 gnd! gnd3ol gndic!

W 0K Cancel |Variahles| Help

Figure 7-10 Import design.

2. To insert power pads, modify the file - power_corner.def which is created with the script
ams_se. Change the lines with PWR4 and GND4 as follows.
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#- GND3 GND3RP |
— GND4 GMDIALLP ;
#- PWR1 YODIIP |
#-— PWR2 YDDIOR
#- PWR3 YOD3IRP
— PWR4 YDDIALLP ;

END COMFOMENTS

SPECIALMETS 7

— wdd3irl! ¢ CORMER1 wddiri1! 3 ¢ CORMERZ wddiri! 3
{ CORMER3 wddir1! 3 ( CORMER4 wddirt! 2
¢ PWR4 wddirill D
¢ GMD4 wddiri! 3
— vddirz2! { CORNER1 wdd3r2! » { CORMER2 wddirz! D
¢ COREMER3 wdd3r2! » { CORMER4 wdd3rz! 2
{ PWR4 wdd3rz! 3
{ GND4 wdd3rz! 3
— wvddio! ¢ CORMER1 wdd3o! 3 ¢ CORNERZ wdd3o! 3
¢ CORMER3 wdd3o! 3 ¢ CORMER4 wdd3o!l 2
¢ PWR4 wvdd3o! 2
¢ GND4 wdd3o! 2
- gnd3o! { CORMER1 gnd3o! 3 { CORMERZ gnd3o! 2
{ CORMERZ gnd3o! 3 ¢ CORMER4 gnd3o! 2
{ PWR4 gndio! 2
O GMD4 gndiol 3
- gnd3r! € CORMER1 gnd3r! 3 ¢ CORMNERZ gnd3r! 2
¢ CORMNER3 gnd3r! 2 ¢ CORMER4 gndir! 2
¢ PWR4 gnd3r! 2
{ GND4 gndir! 2
— wvdd!
{ PWR4 & D
+ SPACIMG MET1 800 RANGE 10000 10000000
+ SPACIMNG METZ 800 RANGE 10000 10000000
+ SPACIMG MET3 200 RANGE 10000 10000000
+ SPACING MET4 200 RANGE 1000 1000000
- gnd!
O GMDd & 3
+ SPACING MET1 200 RANGE 10000 10000000
+ SPACIMNG METZ2 200 RANGE 10000 10000000
+ SPACIMNG MET3 200 RANGE 10000 10000000
+ SPACING MET4 300 REAMGE 1000 1000000 ;

Figure 7-11 Modification of power_corner.def file.

Note: Modify the power_corner.def file accordingly if more power pads are needed.
3. To Load the DEF file, click on File=>Import=>DEF.... Select the power_corner.def in
the Import DEF form, and then click on Ok.
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—| Import DEF |

Filter
+.def

Directory and File List

i Up one directory ]
|power_corner, def
power_corner_c.def

Selection

| fffeleshg/ASIClayout /DEF fpower_corner. def
Options
_| Allow EEQ Substitutions

— Report Fle -

Lib_adder32. importdef. sab. PHWES....

|

| OK | Apply Cancel |Variables| Help

Figure 7-12 Insert power pads.

4. Click on Floorplan->Initialize Floorplan on the SE window, to initialize the floorplan.
The Initialize Floorplan form appears. Change its settings and click on Calculate
button. The form will looks like figure 7-13.

= Initialize Floorplan |
— Design Statistics - | [ Die Size Constraint
Mumber of; ~| | © Aspect Ratio
Cells 66 Elocks 0 i .
I0 Pads 101 IO Pine 0 +~ Height gofecibdun B
Corner Pads 4 Nets 270
Area (Square Microns) el
cells 21385, 000 . - Fixed Size
Blacks 0. 0oo
— 10 To Core Distance - - — Core Area Parameters
; | | Row Utilization(%) a5.0
Left / Right  microns | 1230, 000
Row Spacing tracks ]
= Block Halo Per Side microns . 20 oo
Top/Bottom  microns . | 1230, 000 :
[~ FAip Every Other Row Abut Rows

Calculate|  Expected Results

Aspect Ratio, 1. 00 Width: 3332 150 microns, Height, 3332 150 microns.
Core row utilization = 61 .41%

Chip Area = 11103223 622 sq microns.

I0 to Core Distance (microns): H: 1230000 ¥: 1230000

Mmber of Standard Cell Rows = 14,

Design is pad-limited !

ok | Apply | Cancel | Variables _ Help

Figure 7-13 Initializing floorplan.
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Note:
® |t is better to get a row utilization value 0.6~0.85.

B Click on Help button on the form to get the explanation of the form.
5. Click on Ok on the Initialization Floorplan form. A floorplan appears in the artwork

Window as shown in figure 7-14.

—| Lib_adder3?2 =
Fle Edit View Foorplan Place Route Report Verfy Help
Scale: Big
Obhject S1 ¥s
|Region

| Group

-~

Cell

Het

SWire

Pin

Elockage
L] == i
[I[I[' ,..._E?

L 4 A |
« = -

,,,,,

e Y 4 x -2582. 189 ¥ 1757. 280 dXx 30,740 dy =71, 787 3el

{—I}' (_Jz G_&' B B S e B S e A S
s 3 set v UPDATECOREROW. ELOCEHALD. GLOBAL 20000;
N |

Figure 7-14 Initial floorplan.

Note:
The example serves illustration purpose only. User should limit the number

of 1/0, for better performance.
To verify the floorplan, click on Verify>Floorplan... and click on Ok on the Verify

Floorplan form as figure 7-15. User can change the numbers of errors and warnings.

—-i Verify Floorplan I |

Report Status Only

Limits
Error 1000
Warming 50
oK Cancel | Variables, Help

Figure 7-15 Verify floorplan form.
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7. Click on Report->Infos... and then click on Ok to save the verifying floorplan report to
a file. Read the report to check if there is any error. User can optimize their floorplan
with VSize, referring to SE user guide.

= Report Info |
Filename fl_adder32 info
| Page Limit
Type ALL [ Severity
~ Organize | < Default Warming
<" By Ohject Informational Problem
| HbBoxFmkAran
® | S
W2 e L
| View Report
0K | cancel| Help |

Figure 7-16 Report Info form.

8. To save the floorplan for later use, click on File->Save As... and type a name in the Save
As form as follows.

— Save As |

- Design Directory
me/staff felezhg/ASIC layout /OB, Browse...
- Design Hame

£1 adder32

| Keep Editing Current Design

OK | Cancel | Variables Help

Figure 7-17 Save floorplan.
7.4.4 Viewing the Floorplan

1. To make the floorplan visible, click on the box for Row Visibility (Vs) in the Object
Selection (OS) area.

2. Use the Fit or Redraw icon to set the artwork window size and cause a refresh.

3. Observe the context window. It contains two rectangles. One rectangle encloses the other

rectangle. The white rectangle represents the artwork window and yellow rectangle

represents the chip.

Use the Zoom In and Zoom Out icons to zoom into or zoom out from the chip.

Click on the Display Option icon (in the center, above the Pan icons). The Display

Options form appears.

o s
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To make the row names viewable, do the following
= Move the Display Options form to the right so that you can see the artwork
window.
®  Click on Rows under the Names section (at the left center of the form), then
click on Apply.
The names of the rows appear above each row in the artwork window.
Make rows selectable in the OS area, and click on a row. Notice that the number of row
selected appears in the message window.
Use the Properties icon (to the left of the Display Options icon) to view properties
associated with a specific row.
Go back to the full view of the chip. To fill the artwork window with chip, click Fit icon.

. To turn the row names off, click on Rows under the Names section (Display Options

form), then click on OKk.

Power Planning

Add power strips and power rings accordingly to individual design requirements. For the
design example here, only power ring is needed. Refer to the SE user guide or online help for
details of power planning.

Start SE and load fl_adder32 if SE is closed in the end of last section.

1.

Choose Route->Create Ring..., and the Create Ring form appears. Set the form as
figure 7-18 and click on Ok. The design with power rings (vdd! and gnd!) appears as
figure 7-19.

—-| Create Ring | |

Het(s) |“gnd!® "wddl*

Type
Core ring(s): Exclude selecied ohjects
Offset selection:
- offset from 10
center between 10 and core boundary
Block Ang{s}

around: " sanh Heok
ik anincio BoakApeug of oo viws
S Hser af cplpotod Bodkadaraus af Sorn s |

-chister ot selenieg Bocksiptups ot Core tews |
with sl v aiges

— Ring Configuration

Top : Bottom : Left : Right
'Layer: MET1 . | MET1 | METZ i | METZ
VWidth : 30,00 30,500 | 20,00 3000
Spacing ; | 10-00 1000 0. 900 10 oo
Offset: | 0,900 0,900 - 0. 200 0. 900

oK | Aﬂply_ | Cancel | Variables, Options | Help

Figure 7-18 Create Ring settings.
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Note:
® Users should put the nets’ name as same as that of their netlists.
= The values of metal width and spacing should meet the DRC rule.
B Click on the Help button to explore more of the Create Ring form.

= fl_adder32 B=

Fle Edit View FHoorplan Place Route Report Verify Help
Scale: Big
Ohject 51 Vs
Region

Group

Row LT
cell +
et
Swire ~"
II Fin
Elockage
[ r[ = [ R
[pn ﬂ
A o
« = -
> v 4
ﬂ»

bad 2522708 ¥ 1288302 dX E7. 451 oY 377,788 Sel |0
REFEESH

SET VARTAELE DRAW.CELL.AT ON;

REFRESH

7.

Figure 7-19 Design with power rings.
2. Save the design.
4.6 Place Cells
Start SE and load fl_adder32 if SE is closed in the end of last section.

1. Place Periphery (1/0) cells
Click on Place>10s.... The Place 10 form appears. Set the form as same as figure 7-20,
and then click on Ok. The design in the artwork window is as figure 7-21.



Author — Zheng Huan Qun 96

= Place O |
Placement Mode
Random
10 Constraint File Gpides ine .| Y EgH
Refine Fin Placemen e s an Somn Sidn

Pin Layer Assignment

REC Rt BELTE
L3t 7 fHand BEETT Y
Space : Evenly fhutted - - Center Abutied
7 oK Cancel Help

Figure 7-20 Place 10s.

= fl_adder32 |-
Fle Edit View Floorplan Place Route Report Verify Help

Scale: Big
Object 51 ¥s
Region ~

Group

X -2570.751 ¥ 1613.558 dX 0,000 dy -84, 074 Sel 0

I0PLACE AUTOMATIC STYLE EVEN ;
13:27:52 Begin IOPLACE . ..
REFRESH

13:27.58 T0PLACE finished.

Figure 7-21 The design after placing 1/0 cells.

Note: User may like to refine the 10 cell placement. To do it, check 1/O Constraint File
under the Placement Mode in the Place 10 form, and then click on Write. A file named
ioplace.ioc with all the 10 cells’ name is created. User can modify the file and change the
order of the cells. Finally, run 10 placement in the mode of 1/O Constraint File.
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2. Place CAP cells®
Create a file named capcell.mac as figure 7-22. Click on File->Execute..., and choose
capcell.mac on the Execute form as figure 7-23, and then click on OK. Figure 7-24 shows
the core row area which is before and after placing cap cells.

Me—— &dd cap cells
SEOUTE ADDCELL MODEL EMDCAFL FREFIX Tcap

SPIM wdd! MNET wdd! SPIN and! NET and!

AREA  —dB000000 —d6000000 3 C 46000000 46000000 3 FPREENDCAP
SROUTE aADDCELL MODEL EMDCAFRE PREFIX rcap

SPIM wdd! MET wdd! SPIN gnd! MNET and!

HREA  —dB000000 —d46000000 3 O 4E000000 46000000 3 FOSTEMDCAFR

Figure 7-22 Contents of capcel.mac.

—| Execute |

Filter
* . mac

Directory and Fle List

[ Up one directory ]
|CTGEHS

DB/

\LEF/
DesignLib/
|LEF/

|VERILOG/
\capcell mac
\cds_whin/
(fillcore. mac
(fillperi. mac
1fillperi c.mac
| gemma. mac
pictures

Selection

Jfheme fstaff felezhg/ASIClayout fcapoell. mac

7 OK | Apply | Cancel |Varables| Help

Figure 7-23 The execute form.

*The example is for using AMS design kits. Please refer to the respective foundry if not using AMS design
kits.
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(@) (b)

Figure 7-24 The core area (a) before placing the Cap cells (b) after placing the Cap cells.

3. Place standard cells

Click on Place>Cells.... The Place Cells form appears. Set the form as figure 7-25, and
then click on Ok.

=1 Place Cells |

Timing Driven Flacement
Powrer Driven Placement
Timing Analysis  fBapad §1';§<-.
Fin Placement
Generate Congestion Map
Optimize :
Timing Signal Integrity Scan Chains
(3§§2$z>;_;$m | Bopard Bie | o a0dea 30 apenh, oob

oK Cancel Options Variahles Help

Figure 7-25 The Place Cells form.
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Figure 7-26 The core area after placing standard cells.
4. Save the design as pl_adder32.
7.4.7 Clock Tree Generation
Clock tree generation is described here for user reference. Load the design: pl_adder32 first.

1. Click on Place>Clock Tree Generate (CT Gen).... The CT Gen form appears as
figure 7-27.

— CTGen

Comimand File pl adder3Z. ctgen. cmd ... View
kKeep Comimand File
Run Directory | pl adder3ZCTGenRun

Constraint File |1 5dder32 constraint .. Fdit

Electrical Analysis
Wire Self Heat

oK Apply Cancel | Variables Help

Figure 7-27 CT Gen form.

2. Click on Edit button on the CT Gen form. The CT Gen Constraint form appears. Set
the form as figure 7-28 (user needs to consider the design clock constraint when filling up
the form). Click on the Help button for more information if necessary.
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— CTGen Constraint |

Constraint File Name | pl adder32, constraint Views
Hew Pravisg| Hont | Delete | Tree-

Root 10 Pinh - | | BLOCK

Constraints
Min Delay (ns) | 0 40 Max Delay (ns) ' 2.0
Max Skew (hs) 0.30 Max Transition (ns) 0.0

Clock Waveform Rise Time {ns) 0. 0010 Fall Time {ns) 0. 0010

Specify Tree Options

Define Cell/Structure

0K | Cancel Help

Figure 7-28 CT Gen Constraint form settings.

3. Click on Ok on both the CT Gen and CT Gen Constraint forms. This will create a
design_nameCTGebRun (pr_adder32CTGebRun) directory and a
design_name.ctgen.cmd (pr_adder32.ctgen.cmd) file.

4. Click on Ok on the warning window to save design. CTGen runs and executes the
design_name.ctgen.cmd (pr_adder32.ctgen.cmd) file. After a few mins, the CT Gen
Results come out as figure 7-29.
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— CTGen Results

Exzecution Log Status: | Successful

—————————— e [
{technology) SEVERE WARNING: Port & in cell GND3ALLP has a
(technology) SEVERE WARNING: Port A in cell GHD3IP has mi:
{technology) SEVERE WARNING: Port A in cell GND3FP hasz miz |
(technology) SEVEEE WARNING: Port B in cell VDD3ALLE has n
{technology) SEVERE WARNING: Port & in cell VOD3IP has miz
(techinology) SEVERE WARNING, Port A in cell VDD3RP has mis

—————————— defiint e h
View Reports
Timing Violations | Trace fAnalysis | Overdap | Structure |
Load Results | Cancel | Help

Figure 7-29 CT Gen Results form.

5. Click on Violation button to check if there is any violation. If there is no violation like
figure 7-30, proceed to step 6. Otherwise, manage to solve it.

= Text Editor — final.violations

File Edit Format Options Help

Report: pl_adder3i2CTCGenRun/rpt/final . violations
Design: adder3z

Mo, of max, clock skew wiolations:

Mo, of max. load capacitance wiolations:

Mo, of max. rise transition Lime wiolations:
Mo, of max. fall transition time wiclations:
Mo, of min. rise required time wiolations:
Mo, of min., fall required time wiolations:
Mo, of max. rise required time wiolations:
Mo, of max. fall required time wviolations:

AT -
]

s e e e e e e B e

Figure 7-30 Violation report.

6. Click on the Timing button to check the clock timing, and the results is shown in figure
7-31. User may also view other reports by clicking on the rest buttons.
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Text Editor — final .timing

L=

File Edit Format Options

Help

Report: pl_adderiZCTCenRBun/rpt/final . timing
Design: adder3?

Clock tree root: PIM CLOCK

Timing start pin: +I0PIN CLOCK
Max, transition time at leaf pins:
Min. insertion delay To l=af pins:
Max. insertion delay To leaf pins:
Max ., skew between leaf pins:

Y =

502
924
SobE]

027

—

Figure 7-31 Timing report.

7. Click on Load Results button, and view the messages in the message area.
8. Save the design as CTGen_adder32.

7.4.8 Place Filler Cells

According to the foundry requirement, fillers have to be inserted. Load the design saved in

last section.

1. Place Core Filler Cells*to avoid design rule violations
Click on File=>Execute..., and choose fillcore.mac on the Execute form as figure 7-32,

and then click on Ok.

—4| Execute

Flter
* mac

Directory and Fle List
I Up one directory ]
|CTCEN S

OB/

\DEF S

DesignLlik/

ILEF/

|VERILOG/
lcapoell. mac
jcds_vhin/
fillcore. nac
fillperi. mac
£1llperi c. mac

| germa.; mac

lpicture/

Selection

.home!staff/eleth/ﬁSICflaynut/fillcore.mac

OK | Apply | Cancel |Variahles| Help

Figure 7-32 The execute form.

*User needs to check the foundry requirements if using other design Kits.
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7.4.9

7.4.9.1

7.4.9.2
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Figure 7-33 The core area after placing filler cells.

Place Periphery filler cells®’
Click on File->Execute..., and choose fillperi.mac on the Execute form, and then click
on Ok. The messages appear as figure 7-34.

New cells with prefix fillperi and model neme PERI SPACER 01 P are added.
14:19:17 * SREOUTE ADDCELL * CPU 0 0:00:01 Humber of cells added: 132
Finished execution of file ‘fillperi mac’.

Figure 7-34 Messages of running fillperi.mac.
Save the design.
Viewing a Placed Database
Viewing Placed Cells

To look at the cell instances, select cells visible in the Object Selection area referring to
figure 7-2, and then click on the Redraw icon.

The outlines of placed macro cells appear in green.

Click and drag with the right mouse button to create a rectangle that encloses the cells
which are to be viewed, and then zoom in by making a rectangle in the context window.
To look at the property list of one cell, select the cell and click on the Properties icon.
Click on Cancel on the Edit Properties form to release the form.

Viewing Pins

Make pins viewable in the Object Selection area and click on the Redraw icon.
Select a pin, and then open the properties form by clicking on the Properties icon.
Pins have a large number of properties.

The NAME.CELL is the instance name of the placed cell that contains the pin.

The NAME.NET is the name of the net the pin is connected to. The NAME.PIN is the
name of the pin.

$"User needs to check the foundry requirements if using other design Kits.
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Click on the background of the Artwork window to deselect the pin. The artwork window
shows that no objects are selected.

Click on Cancel to close the Edit Properties form.

To go back to the big picture, click on the Fit icon or use View->Recall Window to go
back to the previous artwork window setting.

7.4.9.3 Viewing Nets

1.

ok w

To open the Display Options form by clicking on the Display Options icon, and make
sure that the Regular Nets (under Routing) is on. If not, turn on Regular Nets and click
on Apply.

Use the following steps to look at net properties:

a. Make nets selectable and visible. Use the Edit=>Find command to highlight a net.
b. On the Find form, set Type to Net, and enter the name of a net.

c. Click on Select on the Find form.

Click and drag the right mouse button to set the window size so it encloses the net.

Use the Ctrl-q (Edit Properties) to view the properties of the highlighted net.

Click on Cancel on the Edit Properties and Find forms.

7.4.10 Routing Power Nets

Load the design saved in section 7.4.8.

1.

Click on Route->Connect Ring... to connect 10 Pads, 10 rings, and Follow Pins to the
power rings. As there is no stripe and block in the design, set the Connect Ring form as
figure 7-35 and then click on Ok.

—-| Connect Ring |
Hets | "gnd3c!" "gnd3o!" "gnd!" "wdd3cZl" "wdd3zll" “wm
Type
Stripe
Block
10 Pad All Ports Mazimum Width
[ 10 Ring Fin Width
Follow Fins Fin Width
oK Apply Cancel Variahles Help

Figure 7-35 Connect Ring form settings.

Note: if your design has power stripe or block, these also need to be selected. All the
selections under Type can be selected all in once and it can also be selected once a time.
Click on Help button for more understanding.
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2. The design after connecting rings is as figure 7-36. Notice that the power pads are not
connected due to the foundry issue. They must be manually connected. Skip to step 6 if
the power pads were connected.

L = LG
L - -
.

.
—
-

Figure 7-36 Design after connecting rings.

3. Click on Edit>Wire>Add..., and the Add Wire form appears. Click on the Help
button for more information about the form. Set the form as figure 7-37, and then connect
the vdd! pad to vdd! net manually.

Add Wire | |

Please select points in art work window
foradding wire segments.

Special Het Reqular Het

Het | wddl; Pick| Mext
Layers
MET1 : METZ Up| Down

Widthl |30 Q00 WAdth2 | 30,000

Direction Options Shape
X-Frst Check DRCs NOME
Y-Frst Check Shorts
o] Bzl Crossover Vias
oK Apply Cancel | Vanables... Help

Figure 7-37 Add Wire form settings.
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4. Repeat step 3 for gnd! pad and gnd! net connection. The design will look as figure 7-38
after connection.

)
7-| pr_adder32
File Edit View Foorplan Place Route Report Verify

Scale: Big
Object 51 Vs

Region

Group

X -2495. 721 Y 586,807 dX -1625.578 dY -303.532 Sel 0

Updated Current DB UNIT to 1000 per micron
Successful LOAD BINARY DESIGN from ‘/home/staff/elezhq/aSIC/layout/DB/pr adderds’
SET VAR DE. DESIGN.DIR " /home/staff/elezhq/aSIC/layout/DE/";

Figure 7-38 Design after connecting power pads manually.

5. Save the design as pr_adder32 by clicking on File> Save As....

7.4.11 Routing all the Nets

After power routing, global & final routing should be done. These two steps can be combined
into one step with Wroute function of cadence SE software. Load the design pr_adder32.

1. Click on Route>WRoute..., and the WRoute form appears as figure 7-39.
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ﬂ ‘WRoute

Routing Mode
Global Route Only

Glohal and Final Route Auto Search And Repair

Incremental Final Route fedey Gilahind Fewdds fop vicdabinns

Timing Drven Routing

0K Cancel Options Variahles Help

Figure 7-39 WRoute settings.

2. Click on Ok on the WRoute form. Click on Help for details of the form if necessary.
3. After a few mins, the artwork window looks as figure 7-40.

_.| final_adder3?2 | ’ |—||

Fle Edit View Foomplan Place Route Report Verfy Help
Scale: Big
Ohject 51 ¥s AAAAAAAAA 1 i /
Region (I F-

2 L

b -1784.780 ¥ 154 317 dX 482,798 dY —348, 248 Sel |0

SAVE DESIGN "/home/staff/elezhq/ASIC/layout/DB/final adderdd" ;
Successful SAVE BINARY DESIGN as ° /home/staff felezhg/ASTIC/layout,/ME/final adder32’

Figure 7-40 Design after WRoulte.
4. Take a note of the message after routing. Manually solve any violation if there was. User

can refer to section 7.4.12, to view the routings.
5. Save the design as final_adder32.

7.4.12 Viewing the Routed Design

1. Open the final routed design. On the Display Option form, turn on only Rows and
Cells&Blocks (under Names), and then click on Apply.
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The first routing step is global routing. Global routing is a plan for final or detail routing.
The router divides the routing grid area of the array into GCells. This array of GCells is
called the GCells grid. To see the GCell grid, click on Global Routing (under Grids) on
the Display Option form and click on Apply. The grid appears in magenta. Zoom in to
view the grid.

The SE Initialize Floorplan command creates the detail routing grid. The router uses the
grid. To view it, click on Detailed Routing on the Display Option form and then click
on Apply.

The grid appears in yellow. Zoom in to view the grid. Each line is called a track. Notice
that each GCell encloses a number of tracks.

After placement, the router considers the location of macro cell pins relative to the
routing grid. To see pins, click on Pins (under Objects) on the Display Options form,
and then click on Apply.

Cell layouts often include internal interconnect wiring that is not part of a pin. The router
must know about these to avoid creating shorts or spacing violations. In the library, these
are modeled as obstructions or blockages associated with a macro. To view the blockages
of macro cells, click on Routing Blockages (under Blockages), and then click on Apply.
The blockages appear in dark blue.

To see the wires created by special router, turn on Special Nets and Special Net Wires
(under Routing). Metal 1 is dark blue and metal 2 is dark red.

To see the detail routing created by WRoute command, turn on Regular Nets and
Regular Net Wires (under Routing), and then click on Apply. Metal 1 wires are dark
blue, metal 2 wires are dark red, and metal 3 wires are dark green. Via openings between
metal 2 and metal 3 are white.

To query a net, make Nets selectable, and use the Properties icon to look at the property
of a net.

Use the Fit icon to fill the artwork window with the design.

7.4.13 Exporting Design

Follow the steps below to export/report design. Take a note of the message in the message
area after click on Ok on each export/report form.

1.

Writing parasitic RC, click on Report>RC... from the menu. The Report RC form
appears. Set the form as figure 7-41 and click on Ok.
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Report Filename.

— I PP
et oG et e e

«.~ D3PF
Hews exuacion Options:

Al

— | HyperExtract-

oK Cancel Variahles Help

Figure 7-41 Report design RC.

2. Writing delay, click on Report->Delay... from the menu. The Report Delay form
appears. Set the form as figure 7-42 and click on Ok.
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= Delay |
Filehame firal adderd?. sdf =l
— Quiput Format — SDF Format
4 Physical SDF 1 & e
. Logical SDF 20 . 30

— Delay Calculation Options

“* Read RSPFIDSPF ‘Ifinal_adder32. repf

-~ Readl SPEF

-~ Report Cross Talk

— Report Cross Talk

Heise Hiwary | x|

Hynercirant SPET PEe |

Bepart 33 ene Preng |

(— Advanmend OO Opliang
Hehn Opliong i Spiysis Gutions Bapor! Dnbiong |

| Gmmwrats Paa Fies Opby

_| View Report

oK | Cancel | Variahles | Help |

Figure 7-42 Report the delay of design.

3. Exporting design in Verilog, click on File->Export->Verilog... from the menu. The
Export Verilog form appears. Set the form as figure 7-43 and click on Ok.

= Export Verilog

— Output Verilog Alename

JFinal adder3z w Browse...|
£

— Options
_| Output Power & Ground Ports

— | Aat Verilog Options:

[ Weriiayg Hiuh Msdie Pieuanm

” e Browse. .

[ e Yidog Dhi Ly ————

7 OK | Cancel | Variables| Help |

Figure 7-43 Export design in Verilog.
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4. Exporting design in DEF, click on File>Export->DEF... from the menu. The Export
DEF form appears. Set the form as figure 7-44 and click on Ok.

= Export DEF |
— DEF File Hame
|[[Einal adder32. def Browse...|
oAl .~ Logical - - Physical
| Cells History
| Hets Modifications
_| Special MHets Constraints
_| Blockages External Fins
_| Flls{Slots Scan Chain
| Vias Layout Modifications
_| Groups | Aliases
7 0K Cancel Variables | Help

Figure 7-44 Export design in DEF.

5. Exporting design in GDSI|I, click on File->Export->GDS I1... from the menu. The
Export GDSII form appears. Set the form as figure 7-45 and click on Ok.

= Export GDSII ]
il GDS-11 File
| final_adder32. gds2 Browse...|
|_- I Map File -
gds2. map Br'uwse..._j
' Report File
final adder3Z gdsf. jnl Browse...|

Structure Hame adder32
Library Name DESIGHNLIE

Hets to Remove

Units Humediniiy

oK | Cancel | Variables Help

Figure 7-45 Export design in GDS II.
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7.5 Conclusion

The digital layout flow with cadence SE is described. User may just follow the steps listed,
for place and route. User can also use script to run the whole process at backend of the x-term
window. For doing so, User may modify the file gemma.mac according to individual design and
then start SE with the file.

User should notice that the technology used for the example is AMS 0.35um. Different design
kits, the method to setup initial environment and design library would be different. User should
change accordingly to vendor requirements.

The next step of ASIC design is to bring the output of layout to NCLaunch and/or primetime
for post-layout verification and/or post-layout static timing analysis.
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8. Post-Layout Verification with NCLaunch

The methods of post-layout and pre-layout verifications are same. The difference of
simulation results between post-layout and pre-layout depends on the SDF files. The post-layout
SDF file includes both delays of nets and cells but pre-layout SDF file includes only the delay of
cells. As the verification methods are same, the SDF back annotation is not repeated. Only the file
preparations are described in this chapter, for user knows what files should be used in the post-
layout verification.

The example used is the adder32. The source and SDF files of the design are got from chapter
7, which are after place and route. The file preparations of post-layout verification are as follows:

1. Create a working directory: routed_ncvlog
% mkdir routed_ncvlog
2. Copy the design source files: final_adder32.v, test_adder.v (referring to chapter 3 for this
file) and SDF file: final_adder32.sdf to the directory: routed ncvlog.
% cd routed_ncvlog
% cp /the path to design files/ final_adder32.v .
% cp /the path to test_adder.v/test_adder.v .
% cp /the path to SDF files/ final_adder32.sdf .
3. Create a lib directory which holds the library files used by the design.
% mkdir lib
4. Copy the library files to the directory lib.
% cp /path to library files/c35_CORELIB.v lib
% cp /path to library files/c35_IOLIB_4M.v lib
% cp /path to library files/udp.v lib
5. Modify the design source file - final_adder32.v to include the $sdf annotate system task
as figure 8-1.

-
imodule adder3z
Ca,b,cin, CLOCK , sum , cout J;

input [31:0] a

input [31:0] b ;

input cin , CLOCEK |

output [31:0]1 sum

output cout

wire [32:0] temp

wire n199 , n19g  , ni , hle?  , nigg , nlgs , nigd , nlg3s , nig2z , nilgl
wire n18d  , n183 |, n188 , nN1&7 , n186 , nN18S |, n184 , n133 |, n182 , ni31
wire n182 , n179  , nI78 , nNI?7  , nIF6  , nNI?E  , nif4 . n173 , niv2  , ni?t
wire mi70 , n169 |, n1B8 , mi67 , n166 , n132 , ni3d , 30, n12es , nl2s
wire n12?2 , ni26 , ni125 , ni24 , niz3 , ni2z , ni21 , n126 , n1t1a , nills
wire n117 ., n116  , n11s5 ., nt14 . n113 , nt1z ., niid L, h11g , nlog , nlde
wire n107 ., nN1GE  , n10s5  , n1G4  , n1Q3 , nig2  , ni21l  , nied |, niGg3  , niez
wire n161  , p160 , n15% , n158 , n157 , n156 , n155 , n154 , n153 , ni52

wire n151 , 155G, nlds , nids  , nld?  , nld4s  , n145  , nid4d , n143 , nidz

wire nitdi . n1d4s . n13a , ni38 . n137 , ni3é , n135 , n134 , n133 , nies

|YDD3ALLE  PWR4 € 2

Figure 8-1 $sdf_annotate system task in the post-layout source file.
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6. Start NCLaunch in the working directory — routed_ncvlog as follows. The files of post-
layout verification are shown as figure 8-2 in the NCLaunch window.
%nclsunch —new&

Directory:ifhnmefstafffelezhqIASICIrouted_ncvlng :j

£35_IOLIB_4h.y*
udp.y®
final_addar3z.v

- test_adder.w

Figure 8-2 Start up of post-layout verification.

Next, users can follow the steps of section 5.4 to finish the post-layout verification.
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9. Post-Layout STA with PrimeTime

Post-layout STA with primetime is described in this chapter. The data used for post-layout
STA is got from cadence silicon ensemble, which is after place and route. The arrangement of the
chapter is as follows. In section 9.1, the overview of post-layout STA is described. It focuses
more on the physical data related topics which are not described in chapter 6 (pre-layout STA).
The constraints of post-layout are given in section 9.2. A tutorial of post-layout STA with the
example adder32 is demonstrated in section 9.3. Conclusion is given in section 9.4.

9.1 Overview of Post-Layout STA

Pre-layout STA with primetime is performed based on cell delays and wire load models, but
post-layout STA with primetime is done with the physical data — delays and parasitics. These data
and relative primetime concepts are briefly described in the following sub-sections.

9.1.1 Parasitic versus SDF

During post-layout STA, back-annotation is done with both SDF and parasitic data, but the

two types of data serve different purposes.

1. SDF back-annotation is used to describe the cell and net delays. There is no cell or net
delay calculation by PT — a “frozen” snapshot.

2. Parasitic back-annotation is used to describe net resistance and capacitance (RC). RCs are
used to perform design rule analysis (for example, max_capacitance) and compute cell
and net delays if no SDF is annotated.

It is best to always back-annotate both, for most accurate timing results. Any timing arcs missing
SDF data will then use parasitic data.

9.1.2 Back-Annotation Command Summary

The following commands are used to read and back-annotate a design. Users may refer to the
manpage of PT for the explanations of the commands.
e read_sdf
O report_annotated delay
0 report_annotated_check
0 remove_annotated_delay
O remove_annotated_check
e read_parasitics
O report_annotated_parasitics
O remove_annotated_parasitics

9.1.3 List of Precedence

If SDF and parasitic data are both annotated, the order of the precedence is as follows.
e SDF.

e SPEF¥/DSPF*/RSPF.

e Lumped RC.

e Wire load models.

% Standard Parasitic Exchange Format.
% Detailed Standard Parasitic Format.
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9.2 Constraints of Post-Layout STA

The constraints of post-layout STA are different from that of pre-layout STA. As the design is
on mask level, two Commands are no more used and they are set clock uncertainty and
set_wire_load_model. Referring to chapter 4, set clock uncertainty models clock skew and
set_wire_load_model specifies the wire load model used for nets. The STA on mask level, the

clock skew and nets are calculated and modeled with the physical data respectively.

9.3 Tutorial of Post-Layout STA Using PrimeTime

The example used is the adder32, and its data is got from chapter 7. The method and flow of
post-layout STA using primetime is shown below. The working directory of the tutorial is as

same as that of doing pre-layout STA.

93.1

1.

3.

Preparations

Create a directory — routed to keep the design data.

% mkdir routed

% cp /path to design data/final_adder32.v routed
% cp /path to design data/final_adder32.sdf routed
% cp /path to design data/final_adder32.rspf routed
Modify the .synopsys_pt_setup file as follows

set_search_path “/path to the installation directory of foundry/synopsys/c35_3.3V/\

/path to the project directory/mapped/db /path to the project directory/routed”
set link_path “* ¢c35_CORELIB.db c35_IOLIB_4M.db”

Modify the constraint file as follows and save it as adder32_pt_routed.scr under the

directory - scripts.

current_design adder32
link
reset_design

set_operating_conditions -analysis_type bc_wec -library ¢c35_CORELIB
-max WORST -min BEST

set_load 0.1 [all_outputs]

set_driving_cell -library c35_CORELIB -lib_cell BUFS8 [all_inputs]
remove_driving_cell [get_ports CLOCK]

#use the real clock tree generated
create_clock -per 100 -name clk [get_ports CLOCK]
set_propagated_clock [get_clocks clk]

#apply default timing constraints
set_input_delay -max 2 -clock clk [all_inputs]
set_input_delay -min 0.4 -clock clk [all_inputs]
remove_input_delay [get_ports CLOCK]
set_output_delay -max 0 -clock clk [all_outputs]
set_output_delay -min 0 -clock clk [all_outputs]
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Start STA with PrimeTime

The followings are the steps to check timing with primetime.

1.

2.

3.

5.

6.

7.

Start primetime

% primetime

Read design with the command - read_verilog.

pt_shell>read_verilog ./routed/final_adder32.v

Execute scripts by click on File=>Execute Script... and choose the file -
adder32_pt_routed.scr under the directory - scripts.

Check timing and report analysis coverage before reading SDF and parasitics to ensure
that there are no problem at this stage. The output is shown in figure 9-1.
pt_shell>check_timing —verbose

pt_shell>report_analysis_coverage

pt_shell: check_timing -verbose

Information: Using automatic max wire Joad selection group “sub_micron’ . CEWNY-0O0:

Information: Using automatic min wire Toad selection group “sub_micron’ . (ENY-003

Warning: Some Liming arcs have been disabled for breaking timing loops
or because of constant propagation. Use the “report_dizable_timing’
command to get the list of these disabled timing arcs, C(PTE-003)

Information: Checking ‘no_clock? .

Information: Checking ‘no_input_delay’ .

Information: Checking ‘partial _input_delay’.

Information: Checking ‘no_driving_cell”.

Information: Checking ‘unconstrained_sendpoints’ .

Information: Checking ‘unexpandable_clocks’ .

Information: Checking ‘generic’ .

Information: Checking ‘latch_fanout”,

Information: Checking ‘loops’.

Information: Checking ‘generated_clocks’ .

check_timing =succeaded.

1

pt_shell: report_analvsis_coverage

U U G S R R R

Feport @ analysis_coverage

Design ; adderiz

Version: W-2004,12-SP2

Date ¢ Thu Feb 16 14:54:52 2006

Tvpe of Check Total Meat Yiolated Untested
setup 99 o 0% 0 0% 99 {(100%)
hold 99 o ¢ 0% 0 0% 99 C100%2
min_pulse_width 66 66 C100%) O 0% 0 ¢ 0Ok)
out_setup 33 33 {100%) O ( 0%} o ¢ 0%
out_hold 33 33 (100%) O 0% o0 0%
411 Checks 330 132 { 40%) O 0% 198 { GO%D

1

Figure 9-1 Messages of check_timing and report_analysis_coverage
before reading physical data.

Read SDF file with the command - read_sdf.

pt_shell>read_sdf ./routed/final_adder32.sdf

Read parasitics file with the command - read_parasitics

pt_shell>read_parasitics ./routed/final_adder32.rspf

Check if all delays are annotated with the command - report_annotated_delay. The
messages are shown in figure 9-2.

pt_shell>report_annotated_delay
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pt_shell: report_annotated_delay
EEEEEEEEEEEEE S SR EEE SRR R R R R R
Report @ anhotated_delay

Design : adderiz

Varsion: W-2004.12-5F2

Date ¢ Thu Feb 16 15:14:39 2006

Aok e okl ool o ol o ok sk ke ok e shodle sl o ol ok sk sl b ol sk ool e ol ol ok ole b e e o sk ok

Delay type | Total
cell arcs | 132
cell arcs (unconnected) | i3
internal net arcs | a9
net arcs from primary inputs | 66
net arcs to primary outputs | 33

| 363

| | NOT |
| d&nnotated | annotated |

+ =

132
i3
99
6o
i3

igs |

Figure 9-2 Messages of report annotated delay.

8. Check if all parasitics are annotated with the command - report_annotated_parasitics.

Figure 9-3 shows the messages.
pt_shell>report_anntoated_parasitics

pt_shell: report_annotated_parasitics
B R R O R U U R DR T U
Report : annotated_parasitics
—internal _nets
—boundary_nets
Desiagn ;. adder3:z
Version, W-2004,12-5SF2
Date . Thu Feb 16 16:13:10 2006

R R T R R T R T T L T U R )

| | | |
et Type | Total | Lumped | RC pi o |
———————————————————— B L e s &
Internal nets | 164 | o 164
- Driverless nets | | o | o |
———————————————————— s S
Boundary /port nets | 9a | o | 99 |
- Driverless nets | | o | |
———————————————————— ety T e
| 263 | o 263 |

RC
natwork

Figure 9-3 Messages of report_annotated parasitics.

L] o R e e

NoT |
Annotated|
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9. Check net RC with the command - report_net —verbose. Some of the messages are shown

in figure 9-4.
pt_shell>report_net -verbose
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Report | het

Design : adderi?

Varsion; W-=2004,12-5F2

Date . Thu Feb 16 15:22.:07 2006

e ol s ok ol ol ok e e ook e ol s o ok e ol o o ok e ol ook ok ol ol ok e e ok

attributes:
c - anhotated capacitance
r - annotated resistance

Cap Resistance
Meat Fanout Fanin minSmax minmax Fins Attributes
CLOCEK 1 1 4.76/4 .76 0,00/0,00 2 c/o,rir
alo] 1 1 4. 76/, 76 0.00/0.00 2 c/c,rir
al1] 1 1 4.76/4.76 0.00/0.00 2 ChC, A
alz] 1 1 4.76/4.76 0.00/0.00 Z CEE A
al3] 1 1 4. 76/4. 76 0.00/0.00 2 ciC,rir
al4] 1 1 4.76/4 .76 0.00/0,00 2 cle,
al5] 1 1 4,76/, 76 0.00/0,00 2 c/c,rir
al&] 1 1 4, 76/4.76 0,00/0,00 2 GG A
al?] 1 1 4, 76/4.76 0,00/0,00 2 c/o,rir
al&] 1 1 4. 76/4. 76 0.00/0.00 2 ciC,rir
al9] 1 1 4. 76/4.76 0.00/0.00 2 G

Figure 9-4 Messages of report net RC.
10. Check timing and analysis coverage, referring to step 4. Figure 9-5 shows the message.

pt_=hells check_timing
Information: Checking
Information: Checking
Information: Checking
Information: Checking
Information: Checking
Information: Checking ’unexpandable_clocks’ .
Information: Checking “generic’.
Information: Checking ‘Tatch_fanout”.
Information: Checking ‘Toops”,

Information: Checking ‘generated_clocks’
check_timing succeeded,

1

pt_shell: report_analysis_coverage

v oo s sk ok ke ol ol e o ol e ol ok ekl el e ol o ol e e ok e e ol ke ol o e o e sk ok e sk
Report ;. analysis_coverage

Design : adder3?

Varsion,; W=2004.12-5F2

Date . Thu Feb 16 15:27:33 2006

e o ok vk oo Mo e we e ole s o 3ok o ol e e e ae ol o ol ool o e o ok e ok ol ol e o ok

no_clock”,
no_input_delay” .

partial _input_delay’ .
no_driving_cell” .
unconstrained_endpoints’ .

4
4
il
.
’
F
.

Tvpe of Check Total Mat violated Untesteaed
Setup 99 o Ok oo 0% 99 (100%D
hold 99 o 0% Q¢ 0% a9 (100%2
min_pul se_width 66 66 (100%) oo Ok O 0%
out_setup 33 33 C100%) o ¢ 0% O 0%
out_hold 33 33 C100%> oo Okl o 0%
#1171 Checks 350 132 { 40%> o0 Ok 198 € 60%)

1

Figure 9-5 Messages of check timing and report analysis coverage
after reading physical data.

11. Generate Timing report with the command - report_timing. The timing report is shown in
figure 9-6.
pt_shell>report_timing
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pt_shell: report_timing
Report  timing
—path full
—delaw max
—max_paths 4
Desigh ¢ adderz2
Yersion: W-2004.12-5F2
Date ! Thu Feb 1E& 15146118 2006

EEE R R R R R R

startpoint: al0] Cinput port clocked by cTk)
Endpaint: sum_reg[31]
[rising edge-triggered f1ip—Tlop clocked by clk)
Fath Sroup: clk
Fath Type: max

Foint Incr Fath
clock clk Crise edge) 0. 00 0. 00
clock network delay (propagated) 2.00 2.00
input external delay 2.00 4,00 T
afo] ©ind 215 % 7.156 T
U7z CITUR) a,.g24 * 7.2 T
add_1_root_add_12_2/8[0] Cadder3z_DWo1_add_33_0) 0.00 = T.ag f
add_1_root_add_12_2/01_0,/C0 CADD3E) 1.1 * 39,14
add_1_root_add_12_2/01_1,/20 [ADD32) .73 * a.823 T
add_1_root_add_12_2/1_2/C0 (ARD3Z) 0.7 10,53 f
add_1_root_add_12_2/1M_3/20 (ADD32) 0,70 11,28 F
add_1_root_add_12_2/01_4/C0 (ADD32) 0,63 * 11,897
add_1_root_add_A2_2/1_5/20 (ADD32) 0,63 * 12,65
add_1_root_add_12_2/01_8/22 (ADD3Z) o, eg 12,234 F
add_1_root_add_12_2/01_7 20 (ADDI2) 0,75 # 14,09 f
add_A_root_add_12_2/01_2/C0 (ADDI2) 0,73 = 14,22 f
add_1_root_add_12_2/501_9/C0 [ADD32) o.71 # 16,62 T
add_1_root_add_12_ 2 01_10/C0 (ADDI2) 0.g39 * 16,22 F
add_1_root_add_12_2/01_11/C0 (ADD3I2) o,gg8 = 16,91 F
add_1_root_add_12_201_12/20 (ADD3I2) 0.8 * 17.589 T
add_1_root_add_12_2/01_13/20 (ADD3IZ) 0.68 * 18,27 T
add_1_root_add_12_2/01_14/20 (ADD3Z) a.7g = 19.01
add_1_root_add_12_2/01_15/C0 (ADD3Z) 0,75 * 19.77
add_1_root_add_12_2/01_16/00 (ADD3Z) 0.7 20,48
add_1_root_add_12_2/01_17/00 CADD32) 0.ea * 21198 F
add_1_root_add_12_2/01_18/C0 CADD32) 0,.ea * 21868 F
add_1_root_add_42_2/01_15/C0 CADDI2) o,ea * z2. 63 f
add_1_root_add_12_2/01_20C00 CADDIE) 0,70 % 22,22
0. i f
o. % f
0. i f
0. % f
0. * f
0. 5 f
o, % f
0. A T
0. 3 f
0. % f
o, i r
o, il r
o, # r

add_1_root_add_12_2/04_21 0 CADDIE) 73 23, 88
add_1_root_add_12_2/U01_22/C0 (ADDI2] 72 24, B2
add_1_root_add_12_2/01_23/C0 (ADDIZ2) == 25, 37
add_1_root_add_12_z2/01_24/C0 (ADDIZ) Ea 2E. OE
add_1_root_add_12_z2/01_25/C0 (ADDIZ) ES 2E. T4
add_1_root_add_12_2/01_Z&/C0 [ADDIZ) Eg 27,42
add_1_root_add_12_z2/1_27/C0 CADDIZ) E7 25,049
add_1_root_add_12_2/U1_28/C0 (ADD3Z) B3 23.79
add_1_root_add_12_2/U1_29/C0 (ADD3Z) B3 29,43
add_1_root_add_12_2/U1_30/C2 (ADD32) 70 30,18
add_A_root_add_A12_2/01_31/5 (ADD32) 24 .12
add_A_root_add_ 12 2/5UM[31] (adder3z_DWod_add_33.00 a]u] .12
sum_reg[31]1/0 (DFS2) ulu} .12
data arrival time 21.42
clock clk Crise edge) 100, 0a 100, 0d
clock network delay (propagated) 1,50 % 101,80
sum_reg[31]1/2 (DFS3] 101,50 r
Tibrary setup time -0.40 ® 101.10
data required time 101.10
data required time 101,10
data arrival time -31.12
slack (MET) g9, 93

Figure 9-6 Post-layout STA timing report.
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12. Check endpoint slack by clicking on Timing->Histogram->Slack.... Figure 9-7 is the
endpoint slack.

«HistList.1  Endpoint Slack

Endpoint Slack W'Narne—l

35 B63.9775 sum_reg[31)D
33 ] TO GRS cout_regdD
an T0.5898 sum_reg[30)D
or 71.2439 sum_reg[23)/D
]
12
10
g

BES4TT4E 97238

7 I:-::-: 3775 32 .31 i‘;l—l

Figure 9-7 Histogram of endpoint slack.

13. Exit primetime. User may check others if necessary.

9.4 Conclusion

The post-layout STA using primetime is presented in this chapter. The difference between
post-layout STA and pre-layout STA is focused. User may refer to chapter 6 — pre-layout STA
and PT user guide while doing post-layout STA, for getting more information.
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